aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-02-24 00:12:23 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-23 19:53:28 +0100
commitc24e01fcccdb8fe3f4a2c9134b584a6076b7c1ef (patch)
tree93b5f49ad9f1f8c5c452363bbc57aded07dc2c2e /target
parent55c153538d894f6fe71404fa3b73cb52ad946d63 (diff)
downloadupstream-c24e01fcccdb8fe3f4a2c9134b584a6076b7c1ef.tar.gz
upstream-c24e01fcccdb8fe3f4a2c9134b584a6076b7c1ef.tar.bz2
upstream-c24e01fcccdb8fe3f4a2c9134b584a6076b7c1ef.zip
kirkwood: fix device node name of Iomega ix2-200
The current device node name of ix2-200 is "iom_ix2_200", which results in a SUPPORTED_DEVICES string "iom,ix2,200" that does not match the compatible in DTS and the board name used in board.d. Fix this by replacing the second underscore with a dash, following vendor_model scheme. Fixes: 27b2f0fc0fc5 ("kirkwood: add support for Iomega Storcenter ix2-200") Signed-off-by: Sungbo Eo <mans0n@gorani.run> [commit title/message rephrase] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/kirkwood/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 9c5681901c..cbdfbc11ec 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -62,7 +62,7 @@ define Device/iom_iconnect-1.1
endef
TARGET_DEVICES += iom_iconnect-1.1
-define Device/iom_ix2_200
+define Device/iom_ix2-200
DEVICE_VENDOR := Iomega
DEVICE_MODEL := StorCenter ix2-200
DEVICE_DTS := kirkwood-iomega_ix2_200
@@ -77,7 +77,7 @@ define Device/iom_ix2_200
IMAGE_SIZE := 32505856
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
endef
-TARGET_DEVICES += iom_ix2_200
+TARGET_DEVICES += iom_ix2-200
define Device/linksys_audi
DEVICE_VENDOR := Linksys