aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-07-14 18:01:00 +0000
committerJohn Crispin <john@openwrt.org>2013-07-14 18:01:00 +0000
commitf7cf157712d95459e6d5c27d061cdc6aa2090c1e (patch)
tree9951d16ae938100d77e75b00d7ac9386703d5e2a /target
parent6d7e4776918652bce5e2b5da1a8f3ce401348af4 (diff)
downloadupstream-f7cf157712d95459e6d5c27d061cdc6aa2090c1e.tar.gz
upstream-f7cf157712d95459e6d5c27d061cdc6aa2090c1e.tar.bz2
upstream-f7cf157712d95459e6d5c27d061cdc6aa2090c1e.zip
ramips: disable ill_acc driver by default
The driver seems to be causoing boot rpoblems on some SoCs Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37314
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/mt7620a/config-3.91
-rw-r--r--target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch22
-rw-r--r--target/linux/ramips/rt288x/config-3.91
-rw-r--r--target/linux/ramips/rt305x/config-3.91
-rw-r--r--target/linux/ramips/rt3883/config-3.91
5 files changed, 17 insertions, 9 deletions
diff --git a/target/linux/ramips/mt7620a/config-3.9 b/target/linux/ramips/mt7620a/config-3.9
index ea7d6bc11a..de16bf0d04 100644
--- a/target/linux/ramips/mt7620a/config-3.9
+++ b/target/linux/ramips/mt7620a/config-3.9
@@ -138,6 +138,7 @@ CONFIG_PERF_USE_VMALLOC=y
CONFIG_PHYLIB=y
# CONFIG_PREEMPT_RCU is not set
CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
CONFIG_RALINK_USBPHY=y
CONFIG_RALINK_WDT=y
# CONFIG_RCU_STALL_COMMON is not set
diff --git a/target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch b/target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch
index c82b7a97c2..e29a52db2c 100644
--- a/target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch
+++ b/target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch
@@ -10,19 +10,23 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
2 files changed, 88 insertions(+), 1 deletion(-)
create mode 100644 arch/mips/ralink/ill_acc.c
---- a/arch/mips/ralink/Makefile
-+++ b/arch/mips/ralink/Makefile
-@@ -6,7 +6,7 @@
- # Copyright (C) 2009-2011 Gabor Juhos <juhosg@openwrt.org>
- # Copyright (C) 2013 John Crispin <blogic@openwrt.org>
+Index: linux-3.9.10/arch/mips/ralink/Makefile
+===================================================================
+--- linux-3.9.10.orig/arch/mips/ralink/Makefile 2013-07-14 10:54:04.242545881 +0200
++++ linux-3.9.10/arch/mips/ralink/Makefile 2013-07-14 11:42:58.726615805 +0200
+@@ -8,6 +8,8 @@
--obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o
-+obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o ill_acc.o
+ obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o
++obj-$(CONFIG_RALINK_ILL_ACC) += ill_acc.o
++
obj-$(CONFIG_SOC_RT288X) += rt288x.o
obj-$(CONFIG_SOC_RT305X) += rt305x.o
---- /dev/null
-+++ b/arch/mips/ralink/ill_acc.c
+ obj-$(CONFIG_SOC_RT3883) += rt3883.o
+Index: linux-3.9.10/arch/mips/ralink/ill_acc.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-3.9.10/arch/mips/ralink/ill_acc.c 2013-07-14 10:54:04.318545882 +0200
@@ -0,0 +1,87 @@
+/*
+ * This program is free software; you can redistribute it and/or modify it
diff --git a/target/linux/ramips/rt288x/config-3.9 b/target/linux/ramips/rt288x/config-3.9
index 561f871d65..598c97231f 100644
--- a/target/linux/ramips/rt288x/config-3.9
+++ b/target/linux/ramips/rt288x/config-3.9
@@ -121,6 +121,7 @@ CONFIG_PERF_USE_VMALLOC=y
CONFIG_PHYLIB=y
# CONFIG_PREEMPT_RCU is not set
CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
# CONFIG_RALINK_USBPHY is not set
CONFIG_RALINK_WDT=y
# CONFIG_RCU_STALL_COMMON is not set
diff --git a/target/linux/ramips/rt305x/config-3.9 b/target/linux/ramips/rt305x/config-3.9
index 72c6082437..eb5232ba29 100644
--- a/target/linux/ramips/rt305x/config-3.9
+++ b/target/linux/ramips/rt305x/config-3.9
@@ -123,6 +123,7 @@ CONFIG_PERF_USE_VMALLOC=y
CONFIG_PHYLIB=y
# CONFIG_PREEMPT_RCU is not set
CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
CONFIG_RALINK_USBPHY=y
CONFIG_RALINK_WDT=y
# CONFIG_RCU_STALL_COMMON is not set
diff --git a/target/linux/ramips/rt3883/config-3.9 b/target/linux/ramips/rt3883/config-3.9
index 8bf49154bf..3db5077a3c 100644
--- a/target/linux/ramips/rt3883/config-3.9
+++ b/target/linux/ramips/rt3883/config-3.9
@@ -128,6 +128,7 @@ CONFIG_PERF_USE_VMALLOC=y
CONFIG_PHYLIB=y
# CONFIG_PREEMPT_RCU is not set
CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
CONFIG_RALINK_USBPHY=y
CONFIG_RALINK_WDT=y
# CONFIG_RCU_STALL_COMMON is not set