aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-14 14:05:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-14 14:05:23 +0000
commitfbde376c53f43a810f40b623b398032883dc0916 (patch)
tree7c9c08058b49badcf086f9af07a1373e9079a5a4 /target
parenta7c5f6708bd398fa1e5456baa7d1249e29761f80 (diff)
downloadupstream-fbde376c53f43a810f40b623b398032883dc0916.tar.gz
upstream-fbde376c53f43a810f40b623b398032883dc0916.tar.bz2
upstream-fbde376c53f43a810f40b623b398032883dc0916.zip
ar71xx: use uimage split for WZR-HP-G300NH
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37293
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g300nh.c12
-rw-r--r--target/linux/ar71xx/image/Makefile24
2 files changed, 25 insertions, 11 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g300nh.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g300nh.c
index 94f352aced..0a3eba9f77 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g300nh.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g300nh.c
@@ -64,13 +64,9 @@ static struct mtd_partition wzrhpg300nh_flash_partitions[] = {
.size = 0x0020000,
.mask_flags = MTD_WRITEABLE,
}, {
- .name = "kernel",
+ .name = "firmware",
.offset = 0x0060000,
- .size = 0x0100000,
- }, {
- .name = "rootfs",
- .offset = 0x0160000,
- .size = 0x1e60000,
+ .size = 0x1f60000,
}, {
.name = "user_property",
.offset = 0x1fc0000,
@@ -81,10 +77,6 @@ static struct mtd_partition wzrhpg300nh_flash_partitions[] = {
.offset = 0x1fe0000,
.size = 0x0020000,
.mask_flags = MTD_WRITEABLE,
- }, {
- .name = "firmware",
- .offset = 0x0060000,
- .size = 0x1f60000,
}
};
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index b50f333d4c..33a03d2f0b 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -292,6 +292,28 @@ define Image/Build/WZRHP64K/initramfs
$(call MkuImageLzma/initramfs,$(2),$(3) $(4))
endef
+define Image/Build/WZRHP128K
+ $(call MkuImageLzma,$(2),$(3))
+ $(call Sysupgrade/KRuImage,$(1),$(2),131072,31850496)
+ if [ -e "$(call sysupname,$(1),$(2))" ]; then \
+ ( \
+ echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
+ dd if=$(call sysupname,$(1),$(2)); \
+ ) > $(call imgname,$(1),$(2))-tftp.bin; \
+ buffalo-enc -p $(4) -v 1.99 \
+ -i $(call sysupname,$(1),$(2)) \
+ -o $(KDIR_TMP)/$(2).enc; \
+ buffalo-tag -b $(4) -p $(4) -a ath -v 1.99 -m 1.01 -l mlang8 \
+ -w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \
+ -i $(KDIR_TMP)/$(2).enc \
+ -o $(call factoryname,$(1),$(2)); \
+ fi
+endef
+
+define Image/Build/WZRHP128K/initramfs
+ $(call MkuImageLzma/initramfs,$(2),$(3) $(4))
+endef
+
define Image/Build/WZRHPG30XNH
$(call MkuImageLzma,$(2),$(3))
$(call Sysupgrade/KRuImage,$(1),$(2),1048576,31850496)
@@ -1013,7 +1035,7 @@ $(eval $(call SingleProfile,WHRHPG300N,$(fs_64k),WLAEAG300N,wlae-ag300n,WLAE-AG3
$(eval $(call SingleProfile,WRT400N,$(fs_64k),WRT400N,wrt400n,WRT400N,ttyS0,115200))
-$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_128k),WZRHPG300NH,wzr-hp-g300nh,WZR-HP-G300NH,ttyS0,115200,WZR-HP-G300NH))
+$(eval $(call SingleProfile,WZRHP128K,$(fs_128k),WZRHPG300NH,wzr-hp-g300nh,WZR-HP-G300NH,ttyS0,115200,WZR-HP-G300NH))
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG300NH2,wzr-hp-g300nh2,WZR-HP-G300NH2,ttyS0,115200,WZR-HP-G300NH2))
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPAG300H,wzr-hp-ag300h,WZR-HP-AG300H,ttyS0,115200,WZR-HP-AG300H))
$(eval $(call SingleProfile,WZRHP64K,$(fs_64k),WZRHPG450H,wzr-hp-g450h,WZR-HP-G450H,ttyS0,115200,WZR-HP-AG450H))