aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl/common.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-22 09:50:09 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-22 12:08:03 +0100
commitceb625439a84c7ea4ab1e39f126b6baffc48d1cd (patch)
tree46fd430073a208627f821711bae6e690ddd14bd7 /toolchain/musl/common.mk
parent1211832977b98c491d1198ab66c4f8ffc0886a87 (diff)
downloadupstream-ceb625439a84c7ea4ab1e39f126b6baffc48d1cd.tar.gz
upstream-ceb625439a84c7ea4ab1e39f126b6baffc48d1cd.tar.bz2
upstream-ceb625439a84c7ea4ab1e39f126b6baffc48d1cd.zip
musl: improve crypt() size hack
Instead of silently downgrading any non-MD5 crypt() request to DES, cleanly fail with return NULL and errno = ENOSYS. This allows callers to notice the missing support instead of the unwanted silent fallback to DES. Also add a menuconfig toolchain option to optionally disable the crypt size hack completely. This can be probably made dependant on SMALL_FLASH or a similar feature indicator in a future commit. Ref: https://github.com/openwrt/openwrt/pull/1331 Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'toolchain/musl/common.mk')
-rw-r--r--toolchain/musl/common.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
index 234709103c..40c6273e63 100644
--- a/toolchain/musl/common.mk
+++ b/toolchain/musl/common.mk
@@ -29,6 +29,7 @@ include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/hardening.mk
TARGET_CFLAGS:= $(filter-out -O%,$(TARGET_CFLAGS))
+TARGET_CFLAGS+= $(if $(CONFIG_MUSL_DISABLE_CRYPT_SIZE_HACK),,-DCRYPT_SIZE_HACK)
MUSL_CONFIGURE:= \
$(TARGET_CONFIGURE_OPTS) \