aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-05-18 17:29:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-05-18 17:29:51 +0000
commit301ee97229491fbdd694e22aefaaf5058b93da48 (patch)
tree669e7440dedb1d73ac5e6035a007d969a889cb0e /tools/firmware-utils/Makefile
parent46b4413fbbf9edef23cb5ec2bfdd5b983d6eb78a (diff)
downloadupstream-301ee97229491fbdd694e22aefaaf5058b93da48.tar.gz
upstream-301ee97229491fbdd694e22aefaaf5058b93da48.tar.bz2
upstream-301ee97229491fbdd694e22aefaaf5058b93da48.zip
bcm963xx: add cfe image tagging utility
This replaces the proprietary bcmImageBuilder program from the Broadcom source drops. It basically adds a 256 bytes header in front of the kernel + rootfs which contains a few text signatures, the locations of the data as well as the checksums of the data and the tag. It also adds a 12 bytes header in front of the LZMA kernel which contains the load address, kernel entry and the size of the compressed LZMA data. Signed-off-by: Axel Gembe <ago@bastart.eu.org> SVN-Revision: 11170
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 3d8e9eaefb..acb429c443 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -30,6 +30,7 @@ define Build/Compile
$(call cc,lzma2eva,-lz)
$(call cc,mkcasfw)
$(call cc,mkfwimage,-lz)
+ $(call cc,imagetag)
endef
define Build/Install