aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mklibs/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2019-07-26 23:45:47 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-07-26 23:50:21 +0200
commit9437012b9ee4dc550e42665b71902cf885169100 (patch)
tree68243f401099be5e37fddbdf15ae745e267c8cb7 /tools/mklibs/Makefile
parent83d5ca2186f7801d94f336e09f8db0a2c5c5d97f (diff)
downloadupstream-9437012b9ee4dc550e42665b71902cf885169100.tar.gz
upstream-9437012b9ee4dc550e42665b71902cf885169100.tar.bz2
upstream-9437012b9ee4dc550e42665b71902cf885169100.zip
tools/mklibs: update to 0.1.44 and convert to Python 3
Since the switch to Python 3 build fails if CONFIG_USE_MKLIBS is set ("Strip unnecessary functions from libraries" in menuconfig) as mklibs hasn't been converted to run on Python 3. * update to most recent upstream version which brings some reproducibility fixes * converted to Python 3 using 2to3 * fixed mixed tab/spaces indentation * fixed use of string.* functions * some more minor fixes to make Python 3 happy Fixes commit 19938c8de7 ("build: switch to Python 3") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'tools/mklibs/Makefile')
-rw-r--r--tools/mklibs/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/tools/mklibs/Makefile b/tools/mklibs/Makefile
index 507c2fd394..48b1eace40 100644
--- a/tools/mklibs/Makefile
+++ b/tools/mklibs/Makefile
@@ -7,17 +7,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mklibs
-PKG_VERSION:=0.1.35
+PKG_VERSION:=0.1.44
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
-PKG_HASH:=ccb1023dc1729c5a37ca6c3eca8e4bac3491116763c8820dfce8eea4845c8567
+PKG_HASH:=3af0b6bd35e5b6fc58d8b68827fbae2ff6b7e20dd2b238ccb9b49d84722066c2
HOST_FIXUP:=autoreconf
include $(INCLUDE_DIR)/host-build.mk
HOST_CFLAGS += -I$(CURDIR)/include
+HOST_CPPFLAGS += -std=gnu++98
define Host/Install
$(INSTALL_BIN) \