aboutsummaryrefslogtreecommitdiffstats
path: root/tools/upx/Makefile
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2017-03-12 19:58:08 +0100
committerJohn Crispin <john@phrozen.org>2017-03-20 08:26:35 +0100
commit0685f2a66cbb4d39417f168cfb37ae6fa7dbf6cb (patch)
tree11c2b94076e68a71ba4538f9b27fb54a59d498da /tools/upx/Makefile
parentcc5721c3b8e399126a270fd46f5ac4dffc9b3319 (diff)
downloadupstream-0685f2a66cbb4d39417f168cfb37ae6fa7dbf6cb.tar.gz
upstream-0685f2a66cbb4d39417f168cfb37ae6fa7dbf6cb.tar.bz2
upstream-0685f2a66cbb4d39417f168cfb37ae6fa7dbf6cb.zip
tools/upx: Remove from repo
Remove upx from repo, it hasn't been used for a very long time and serves little to no purpose. Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'tools/upx/Makefile')
-rw-r--r--tools/upx/Makefile36
1 files changed, 0 insertions, 36 deletions
diff --git a/tools/upx/Makefile b/tools/upx/Makefile
deleted file mode 100644
index 800b595abe..0000000000
--- a/tools/upx/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-#
-# Copyright (C) 2011-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=upx
-PKG_VERSION:=3.91
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.bz2
-PKG_SOURCE_URL:=https://github.com/upx/upx/releases/download/v$(PKG_VERSION)
-PKG_HASH:=527ce757429841f51675352b1f9f6fc8ad97b18002080d7bf8672c466d8c6a3c
-PKG_CAT:=bzcat
-
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)-src
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Compile
- rm -f $(HOST_BUILD_DIR)/src/.depend
- $(MAKE) UPX_LZMADIR="$(BUILD_DIR_HOST)/lzma-4.65" -C $(HOST_BUILD_DIR)/src \
- CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS)" \
- CXX="$(HOSTCXX)"
-endef
-
-define Host/Install
- $(CP) $(HOST_BUILD_DIR)/src/upx.out $(STAGING_DIR_HOST)/bin/upx
-endef
-
-define Host/Clean
- rm -f $(STAGING_DIR_HOST)/bin/upx
-endef
-
-$(eval $(call HostBuild))