aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-24 01:18:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-24 01:18:49 +0000
commit52339a50fd7966be0ee33c03ffb12a7c0c8842fd (patch)
tree7ce9840a4d188df69d4c87e90404ecb80a383ebc /tools
parent13189afcc913287eecec26634df53a003f3e4812 (diff)
downloadupstream-52339a50fd7966be0ee33c03ffb12a7c0c8842fd.tar.gz
upstream-52339a50fd7966be0ee33c03ffb12a7c0c8842fd.tar.bz2
upstream-52339a50fd7966be0ee33c03ffb12a7c0c8842fd.zip
optimize tools/ directory build order to improve parallel building performance
SVN-Revision: 15365
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 72a25b5b0c..54520bc75c 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -9,11 +9,14 @@
curdir:=tools
# subdirectories to descend into
-tools-y := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config m4 autoconf automake bison quilt yaffs2
+tools-y :=
+tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
+tools-y += m4 autoconf automake bison pkg-config sed
+tools-y += sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage
+tools-y += firmware-utils patch-cmdline quilt yaffs2
tools-$(CONFIG_CCACHE) += ccache
tools-$(CONFIG_powerpc) += dtc
-tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
# builddir dependencies
$(curdir)/squashfs/compile := $(curdir)/lzma/install