aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/mvebu/image/Makefile8
-rw-r--r--target/linux/mvebu/image/cortex-a53.mk4
-rw-r--r--target/linux/mvebu/image/cortex-a72.mk4
-rw-r--r--target/linux/mvebu/image/cortex-a9.mk4
4 files changed, 8 insertions, 12 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index ce1344a547..6dd7bde7ae 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -116,8 +116,16 @@ define Device/NAND-512K
PAGESIZE := 4096
endef
+ifeq ($(SUBTARGET),cortexa9)
include cortex-a9.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa53)
include cortex-a53.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa72)
include cortex-a72.mk
+endif
$(eval $(call BuildImage))
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
index f5313429af..e58a3c42b9 100644
--- a/target/linux/mvebu/image/cortex-a53.mk
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -1,5 +1,3 @@
-ifeq ($(SUBTARGET),cortexa53)
-
define Device/globalscale_espressobin
$(call Device/Default-arm64)
DEVICE_VENDOR := Marvell
@@ -73,5 +71,3 @@ define Device/methode_udpu
BOOT_SCRIPT := udpu
endef
TARGET_DEVICES += methode_udpu
-
-endif
diff --git a/target/linux/mvebu/image/cortex-a72.mk b/target/linux/mvebu/image/cortex-a72.mk
index 5e619804e8..6abee2d8b9 100644
--- a/target/linux/mvebu/image/cortex-a72.mk
+++ b/target/linux/mvebu/image/cortex-a72.mk
@@ -1,5 +1,3 @@
-ifeq ($(SUBTARGET),cortexa72)
-
define Device/marvell_macchiatobin
$(call Device/Default-arm64)
DEVICE_VENDOR := SolidRun
@@ -29,5 +27,3 @@ define Device/marvell_armada7040-db
IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
endef
TARGET_DEVICES += marvell_armada7040-db
-
-endif
diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
index c2ada75c2d..389082e426 100644
--- a/target/linux/mvebu/image/cortex-a9.mk
+++ b/target/linux/mvebu/image/cortex-a9.mk
@@ -6,8 +6,6 @@
# See /LICENSE for more information.
#
-ifeq ($(SUBTARGET),cortexa9)
-
define Device/linksys
$(Device/NAND-128K)
DEVICE_VENDOR := Linksys
@@ -218,5 +216,3 @@ define Device/cznic_turris-omnia
SUPPORTED_DEVICES += armada-385-turris-omnia
endef
TARGET_DEVICES += cznic_turris-omnia
-
-endif