aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/rbcfg/Makefile2
-rw-r--r--package/boot/rbcfg/src/main.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/boot/rbcfg/Makefile b/package/boot/rbcfg/Makefile
index 55e0ea7490..874ef06924 100644
--- a/package/boot/rbcfg/Makefile
+++ b/package/boot/rbcfg/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rbcfg
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/package/boot/rbcfg/src/main.c b/package/boot/rbcfg/src/main.c
index 2acbfbd8cb..7da46f90a5 100644
--- a/package/boot/rbcfg/src/main.c
+++ b/package/boot/rbcfg/src/main.c
@@ -498,7 +498,7 @@ rbcfg_update(int tmp)
put_u32(ctx->buf + 4, crc);
name = (tmp) ? ctx->tmp_file : ctx->mtd_device;
- fd = open(name, O_WRONLY | O_CREAT);
+ fd = open(name, O_WRONLY | O_CREAT, 0640);
if (fd < 0) {
fprintf(stderr, "unable to open %s for writing\n", name);
err = RB_ERR_IO;