aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rw-r--r--target/linux/ar71xx/image/generic-ubnt.mk6
2 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 03dfbcebf9..044ef4eae5 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -111,6 +111,9 @@ ubnt_unifi_ac_board_detect() {
"e517")
model="Ubiquiti UniFi-AC-LITE"
;;
+ "e527")
+ model="Ubiquiti UniFi-AC-LR"
+ ;;
"e537")
model="Ubiquiti UniFi-AC-PRO"
;;
diff --git a/target/linux/ar71xx/image/generic-ubnt.mk b/target/linux/ar71xx/image/generic-ubnt.mk
index 5a4517f81f..b82ac8686f 100644
--- a/target/linux/ar71xx/image/generic-ubnt.mk
+++ b/target/linux/ar71xx/image/generic-ubnt.mk
@@ -138,6 +138,12 @@ define Device/ubnt-unifiac-lite
endef
TARGET_DEVICES += ubnt-unifiac-lite
+define Device/ubnt-unifiac-lr
+ $(Device/ubnt-unifiac-lite)
+ DEVICE_TITLE := Ubiquiti UniFi AC-LR
+endef
+TARGET_DEVICES += ubnt-unifiac-lr
+
define Device/ubnt-unifiac-mesh
$(Device/ubnt-unifiac-lite)
DEVICE_TITLE := Ubiquiti UniFi AC-Mesh