aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-sunxi/Makefile9
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk10
2 files changed, 19 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 056300e189..321e7e9c03 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -168,6 +168,14 @@ define U-Boot/pangolin
UENV:=pangolin
endef
+define U-Boot/nanopi_neo_plus2
+ BUILD_SUBTARGET:=cortexa53
+ NAME:=NanoPi NEO Plus2 (H5)
+ BUILD_DEVICES:=sun50i-h5-nanopi-neo-plus2
+ DEPENDS:=+PACKAGE_u-boot-nanopi_neo_plus2:arm-trusted-firmware-sunxi
+ UENV:=a64
+endef
+
define U-Boot/pine64_plus
BUILD_SUBTARGET:=cortexa53
NAME:=Pine64 Plus A64
@@ -197,6 +205,7 @@ UBOOT_TARGETS := \
Lamobo_R1 \
nanopi_m1_plus \
nanopi_neo \
+ nanopi_neo_plus2 \
orangepi_r1 \
orangepi_plus \
orangepi_2 \
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index bbb253f0ae..eb31aa8d4c 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -7,6 +7,16 @@
#
ifeq ($(SUBTARGET),cortexa53)
+define Device/sun50i-h5-nanopi-neo-plus2
+ DEVICE_TITLE:=Nanopi NEO Plus2 (H5)
+ SUPPORTED_DEVICES:=nanopi-neo-plus2
+ SUNXI_DTS:=allwinner/sun50i-h5-nanopi-neo-plus2
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-h5-nanopi-neo-plus2
+
define Device/sun50i-a64-pine64-plus
DEVICE_TITLE:=Pine64 Plus A64
SUPPORTED_DEVICES:=pine64,pine64-plus