aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/at91/image/Makefile2
-rw-r--r--target/linux/at91/image/sama5.mk4
2 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 3b01d42131..adb7c6d0ba 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -63,6 +63,8 @@ define Device/evaluation-dtb
$(Device/evaluation-zImage)
IMAGES += dtb
IMAGE/dtb := install-dtb
+ KERNEL_SUFFIX := -fit-zImage.itb
+ KERNEL := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
endef
define Device/evaluation-fit
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index a737ba508b..1e4366cefa 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -11,7 +11,9 @@ define Build/at91-sdcard
rm -f $@.boot
mkfs.fat -C $@.boot $(FAT32_BLOCKS)
- mcopy -i $@.boot $(KDIR)/zImage ::zImage
+ mcopy -i $@.boot \
+ $(KDIR)/$(DEVICE_NAME)-fit-zImage.itb \
+ ::$(DEVICE_NAME:at91-%=%)-fit.itb
$(if $(findstring at91-sama5d27_som1_ek,$@), \
mcopy -i $@.boot \