aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ath79/dts/qca9531_alfa-network_pi-wifi4.dts87
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/01_leds4
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/ath79/image/generic.mk9
4 files changed, 102 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/qca9531_alfa-network_pi-wifi4.dts b/target/linux/ath79/dts/qca9531_alfa-network_pi-wifi4.dts
new file mode 100644
index 0000000000..42f2c9ffe5
--- /dev/null
+++ b/target/linux/ath79/dts/qca9531_alfa-network_pi-wifi4.dts
@@ -0,0 +1,87 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9531_alfa-network_r36a.dtsi"
+
+/ {
+ model = "ALFA Network Pi-WiFi4";
+ compatible = "alfa-network,pi-wifi4", "qca,qca9531";
+
+ aliases {
+ led-boot = &led_usb;
+ led-failsafe = &led_usb;
+ led-upgrade = &led_usb;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&enable_gpio4 &enable_gpio16>;
+
+ lan_data {
+ label = "orange:lan_data";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ };
+
+ lan_link {
+ label = "green:lan_link";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ };
+
+ led_usb: usb {
+ label = "green:usb";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "usbport";
+ trigger-sources = <&gl850g_port1>, <&gl850g_port2>,
+ <&gl850g_port3>, <&gl850g_port4>;
+ };
+
+ wlan {
+ label = "blue:wlan";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+ };
+};
+
+&eth0 {
+ mtd-mac-address = <&art 0x1002>;
+ mtd-mac-address-increment = <(-1)>;
+};
+
+&eth1 {
+ compatible = "syscon", "simple-mfd";
+};
+
+&gpio_export {
+ usb-power {
+ gpio-export,name = "usb-power";
+ gpio-export,output = <1>;
+ gpios = <&gpio 3 GPIO_ACTIVE_HIGH>;
+ };
+};
+
+&hub_port0 {
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ gl850g_port1: port@1 {
+ reg = <1>;
+ #trigger-source-cells = <0>;
+ };
+
+ gl850g_port2: port@2 {
+ reg = <2>;
+ #trigger-source-cells = <0>;
+ };
+
+ gl850g_port3: port@3 {
+ reg = <3>;
+ #trigger-source-cells = <0>;
+ };
+
+ gl850g_port4: port@4 {
+ reg = <4>;
+ #trigger-source-cells = <0>;
+ };
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 08ca2a8398..a345dca4af 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -40,6 +40,10 @@ alfa-network,n5q)
ucidef_set_led_rssi "signal3" "SIGNAL3" "green:signal3" "wlan0" "50" "100"
ucidef_set_led_rssi "signal4" "SIGNAL4" "green:signal4" "wlan0" "75" "100"
;;
+alfa-network,pi-wifi4)
+ ucidef_set_led_netdev "lan_data" "LAN_DATA" "orange:lan_data" "eth0" "tx rx"
+ ucidef_set_led_netdev "lan_link" "LAN_LINK" "green:lan_link" "eth0" "link"
+ ;;
alfa-network,r36a)
ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
ucidef_set_led_switch "wan" "WAN" "blue:wan" "switch0" "0x10"
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 4d0766d262..d03399a054 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -13,6 +13,7 @@ ath79_setup_interfaces()
adtran,bsap1840|\
allnet,all-wap02860ac|\
alfa-network,ap121f|\
+ alfa-network,pi-wifi4|\
arduino,yun|\
aruba,ap-105|\
avm,fritz1750e|\
@@ -418,6 +419,7 @@ ath79_setup_macs()
alfa-network,ap121fe|\
alfa-network,n2q|\
alfa-network,n5q|\
+ alfa-network,pi-wifi4|\
alfa-network,r36a|\
engenius,ens202ext-v1)
label_mac=$(mtd_get_mac_binary art 0x1002)
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index dc91e1b6d9..fc8b136c51 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -257,6 +257,15 @@ define Device/alfa-network_n5q
endef
TARGET_DEVICES += alfa-network_n5q
+define Device/alfa-network_pi-wifi4
+ SOC := qca9531
+ DEVICE_VENDOR := ALFA Network
+ DEVICE_MODEL := Pi-WiFi4
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport -swconfig
+ IMAGE_SIZE := 15872k
+endef
+TARGET_DEVICES += alfa-network_pi-wifi4
+
define Device/alfa-network_r36a
SOC := qca9531
DEVICE_VENDOR := ALFA Network