aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/dts/mt7621_hiwifi_hc5962.dts6
-rw-r--r--target/linux/ramips/image/mt7621.mk5
2 files changed, 4 insertions, 7 deletions
diff --git a/target/linux/ramips/dts/mt7621_hiwifi_hc5962.dts b/target/linux/ramips/dts/mt7621_hiwifi_hc5962.dts
index 9d60d509ab..ec76b35840 100644
--- a/target/linux/ramips/dts/mt7621_hiwifi_hc5962.dts
+++ b/target/linux/ramips/dts/mt7621_hiwifi_hc5962.dts
@@ -74,12 +74,12 @@
partition@140000 {
label = "kernel";
- reg = <0x140000 0x200000>;
+ reg = <0x140000 0x400000>;
};
- partition@340000 {
+ partition@540000 {
label = "ubi";
- reg = <0x340000 0x1E00000>;
+ reg = <0x540000 0x1c00000>;
};
partition@2140000 {
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 6e64fb8bf1..a72f758c96 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -339,7 +339,7 @@ TARGET_DEVICES += gnubee_gb-pc2
define Device/hiwifi_hc5962
BLOCKSIZE := 128k
PAGESIZE := 2048
- KERNEL_SIZE := 2097152
+ KERNEL_SIZE := 4096k
UBINIZE_OPTS := -E 5
IMAGE_SIZE := 32768k
IMAGES += factory.bin
@@ -349,9 +349,6 @@ define Device/hiwifi_hc5962
DEVICE_VENDOR := HiWiFi
DEVICE_MODEL := HC5962
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 wpad-basic
- SUPPORTED_DEVICES += hc5962
- # Kernel partition too small
- DEFAULT := n
endef
TARGET_DEVICES += hiwifi_hc5962