aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-oxnas/Makefile4
-rw-r--r--target/linux/oxnas/image/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/boot/uboot-oxnas/Makefile b/package/boot/uboot-oxnas/Makefile
index 32ee107e7b..daa266ea8c 100644
--- a/package/boot/uboot-oxnas/Makefile
+++ b/package/boot/uboot-oxnas/Makefile
@@ -29,8 +29,8 @@ endef
UBOOT_TARGETS:=ox820
define Build/InstallDev
- $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
- $(KERNEL_BUILD_DIR)/u-boot.bin
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+ $(CP) $(PKG_BUILD_DIR)/u-boot.bin $(STAGING_DIR_IMAGE)/u-boot.bin
endef
$(eval $(call BuildPackage/U-Boot))
diff --git a/target/linux/oxnas/image/Makefile b/target/linux/oxnas/image/Makefile
index 7ad05844cc..bfa0f0cca7 100644
--- a/target/linux/oxnas/image/Makefile
+++ b/target/linux/oxnas/image/Makefile
@@ -15,7 +15,7 @@ DEVICE_VARS += DTS UBIFS_OPTS
KERNEL_LOADADDR := 0x60008000
define Build/ubootable
- (dd if="$(KDIR)/u-boot.bin" bs=128k conv=sync; \
+ (dd if="$(STAGING_DIR_IMAGE)/u-boot.bin" bs=128k conv=sync; \
dd if="$@" bs=128k conv=sync ) >> $@.new
@mv "$@.new" "$@"
endef