aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 936a1327fd..15d67b4679 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -313,6 +313,23 @@ endef
$(eval $(call KernelPackage,gpio-it87))
+define KernelPackage/gpio-amd-fch
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=@GPIO_SUPPORT @TARGET_x86
+ TITLE:=GPIO support for AMD Fusion Controller Hub (G-series SOCs)
+ KCONFIG:=CONFIG_GPIO_AMD_FCH
+ FILES:=$(LINUX_DIR)/drivers/gpio/gpio-amd-fch.ko
+ AUTOLOAD:=$(call AutoLoad,25,gpio-amd-fch,1)
+endef
+
+define KernelPackage/gpio-amd-fch/description
+ This option enables driver for GPIO on AMDs Fusion Controller Hub,
+ as found on G-series SOCs (eg. GX-412TC)
+endef
+
+$(eval $(call KernelPackage,gpio-amd-fch))
+
+
define KernelPackage/ppdev
SUBMENU:=$(OTHER_MENU)
TITLE:=Parallel port support