aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds7
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network6
-rw-r--r--target/linux/ath79/dts/qca9533_tl-wr841-v9.dts12
-rw-r--r--target/linux/ath79/dts/qca9533_tl-wr841.dtsi142
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk9
5 files changed, 175 insertions, 1 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index 4fa4434efe..e73a0a03c9 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -66,6 +66,13 @@ case "$board" in
ucidef_set_led_switch "lan3" "LAN3" "tp-link:green:lan3" "switch0" "0x10"
ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x02"
;;
+"tplink,tl-wr841n-v9")
+ ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth0"
+ ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
+ ucidef_set_led_switch "lan2" "LAN2" "tp-link:green:lan2" "switch0" "0x08"
+ ucidef_set_led_switch "lan3" "LAN3" "tp-link:green:lan3" "switch0" "0x04"
+ ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x02"
+ ;;
esac
board_config_flush
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index b209bdad29..a4d91fcdf2 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -83,7 +83,11 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
;;
-
+ "tplink,tl-wr841n-v9")
+ ucidef_set_interface_wan "eth0"
+ ucidef_add_switch "switch0" \
+ "0@eth1" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
+ ;;
"tplink,tl-wr1043nd-v1")
ucidef_add_switch "switch0" \
"1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "5@eth0"
diff --git a/target/linux/ath79/dts/qca9533_tl-wr841-v9.dts b/target/linux/ath79/dts/qca9533_tl-wr841-v9.dts
new file mode 100644
index 0000000000..b82fd5adf9
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_tl-wr841-v9.dts
@@ -0,0 +1,12 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9533_tl-wr841.dtsi"
+
+/ {
+ compatible = "tplink,tl-wr841n-v9", "qca,qca9533";
+ model = "TP-Link TL-WR841N/ND Version 9";
+};
diff --git a/target/linux/ath79/dts/qca9533_tl-wr841.dtsi b/target/linux/ath79/dts/qca9533_tl-wr841.dtsi
new file mode 100644
index 0000000000..4219125300
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_tl-wr841.dtsi
@@ -0,0 +1,142 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9533.dtsi"
+
+/ {
+ chosen {
+ bootargs = "console=ttyS0,115200n8";
+ };
+
+ aliases {
+ led-status = &system;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ wifi {
+ label = "tp-link:green:wlan";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ linux,default-trigger = "phy0tpt";
+ };
+
+ system: wifi_qss {
+ label = "tp-link:green:qss";
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ wan {
+ label = "tp-link:green:wan";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ lan1 {
+ label = "tp-link:green:lan1";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ lan2 {
+ label = "tp-link:green:lan2";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ lan3 {
+ label = "tp-link:green:lan3";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ lan4 {
+ label = "tp-link:green:lan4";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ reset {
+ label = "Reset button";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ rfkill {
+ label = "RFKILL button";
+ linux,code = <KEY_RFKILL>;
+ gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "firmware";
+ reg = <0x020000 0x3d0000>;
+ };
+
+ art: partition@3f0000 {
+ label = "art";
+ reg = <0x3f0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&eth1 {
+ mtd-mac-address = <&uboot 0x1fc00>;
+};
+
+&eth0 {
+ status = "okay";
+ phy-handle = <&swphy4>;
+
+ mtd-mac-address = <&uboot 0x1fc00>;
+ mtd-mac-address-increment = <1>;
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&uboot 0x1fc00>;
+};
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index fa937b6bd5..6abc8365fb 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -86,3 +86,12 @@ define Device/tl-wr841-v7
SUPPORTED_DEVICES := tplink,tl-wr841-v7 tl-wr841-v7
endef
TARGET_DEVICES += tl-wr841-v7
+
+define Device/tl-wr841-v9
+ $(Device/tplink-4mlzma)
+ ATH_SOC := qca9533
+ DEVICE_TITLE := TP-LINK TL-WR841N/ND v9
+ TPLINK_HWID := 0x08410009
+ SUPPORTED_DEVICES := tplink,tl-wr841n-v9 tl-wr841n-v9
+endef
+TARGET_DEVICES += tl-wr841-v9