aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ath79/dts/ar9344_tplink_cpe.dtsi6
-rw-r--r--tools/firmware-utils/Makefile2
-rw-r--r--tools/firmware-utils/src/tplink-safeloader.c44
3 files changed, 26 insertions, 26 deletions
diff --git a/target/linux/ath79/dts/ar9344_tplink_cpe.dtsi b/target/linux/ath79/dts/ar9344_tplink_cpe.dtsi
index 9a6f0ea5ab..e8a3bdc399 100644
--- a/target/linux/ath79/dts/ar9344_tplink_cpe.dtsi
+++ b/target/linux/ath79/dts/ar9344_tplink_cpe.dtsi
@@ -72,12 +72,12 @@
partition@0 {
label = "kernel";
- reg = <0x000000 0x200000>;
+ reg = <0x000000 0x300000>;
};
- partition@200000 {
+ partition@300000 {
label = "rootfs";
- reg = <0x200000 0x580000>;
+ reg = <0x300000 0x480000>;
};
};
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 4fcda7e439..39c3503886 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME := firmware-utils
-PKG_RELEASE := 2
+PKG_RELEASE := 3
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/kernel.mk
diff --git a/tools/firmware-utils/src/tplink-safeloader.c b/tools/firmware-utils/src/tplink-safeloader.c
index ec8d084299..501b396343 100644
--- a/tools/firmware-utils/src/tplink-safeloader.c
+++ b/tools/firmware-utils/src/tplink-safeloader.c
@@ -140,8 +140,8 @@ static struct device_info boards[] = {
{"default-mac", 0x30000, 0x00020},
{"product-info", 0x31100, 0x00100},
{"signature", 0x32000, 0x00400},
- {"os-image", 0x40000, 0x200000},
- {"file-system", 0x240000, 0x570000},
+ {"os-image", 0x40000, 0x300000},
+ {"file-system", 0x340000, 0x470000},
{"soft-version", 0x7b0000, 0x00100},
{"support-list", 0x7b1000, 0x00400},
{"user-config", 0x7c0000, 0x10000},
@@ -263,8 +263,8 @@ static struct device_info boards[] = {
{"default-mac", 0x30000, 0x00020},
{"product-info", 0x31100, 0x00100},
{"signature", 0x32000, 0x00400},
- {"os-image", 0x40000, 0x200000},
- {"file-system", 0x240000, 0x570000},
+ {"os-image", 0x40000, 0x300000},
+ {"file-system", 0x340000, 0x470000},
{"soft-version", 0x7b0000, 0x00100},
{"support-list", 0x7b1000, 0x00400},
{"user-config", 0x7c0000, 0x10000},
@@ -342,8 +342,8 @@ static struct device_info boards[] = {
{"default-mac", 0x30000, 0x00020},
{"product-info", 0x31100, 0x00100},
{"signature", 0x32000, 0x00400},
- {"os-image", 0x40000, 0x200000},
- {"file-system", 0x240000, 0x570000},
+ {"os-image", 0x40000, 0x300000},
+ {"file-system", 0x340000, 0x470000},
{"soft-version", 0x7b0000, 0x00100},
{"support-list", 0x7b1000, 0x00400},
{"user-config", 0x7c0000, 0x10000},
@@ -384,8 +384,8 @@ static struct device_info boards[] = {
{"default-mac", 0x30000, 0x00020},
{"product-info", 0x31100, 0x00100},
{"signature", 0x32000, 0x00400},
- {"os-image", 0x40000, 0x200000},
- {"file-system", 0x240000, 0x570000},
+ {"os-image", 0x40000, 0x300000},
+ {"file-system", 0x340000, 0x470000},
{"soft-version", 0x7b0000, 0x00100},
{"support-list", 0x7b1000, 0x00400},
{"user-config", 0x7c0000, 0x10000},
@@ -426,8 +426,8 @@ static struct device_info boards[] = {
{"default-mac", 0x30000, 0x00020},
{"product-info", 0x31100, 0x00100},
{"signature", 0x32000, 0x00400},
- {"os-image", 0x40000, 0x200000},
- {"file-system", 0x240000, 0x570000},
+ {"os-image", 0x40000, 0x300000},
+ {"file-system", 0x340000, 0x470000},
{"soft-version", 0x7b0000, 0x00100},
{"support-list", 0x7b1000, 0x00400},
{"user-config", 0x7c0000, 0x10000},
@@ -466,8 +466,8 @@ static struct device_info boards[] = {
{"default-mac", 0x30000, 0x00020},
{"product-info", 0x31100, 0x00100},
{"signature", 0x32000, 0x00400},
- {"os-image", 0x40000, 0x200000},
- {"file-system", 0x240000, 0x570000},
+ {"os-image", 0x40000, 0x300000},
+ {"file-system", 0x340000, 0x470000},
{"soft-version", 0x7b0000, 0x00100},
{"support-list", 0x7b1000, 0x00400},
{"user-config", 0x7c0000, 0x10000},
@@ -506,8 +506,8 @@ static struct device_info boards[] = {
{"default-mac", 0x30000, 0x00020},
{"product-info", 0x31100, 0x00100},
{"signature", 0x32000, 0x00400},
- {"os-image", 0x40000, 0x200000},
- {"file-system", 0x240000, 0x570000},
+ {"os-image", 0x40000, 0x300000},
+ {"file-system", 0x340000, 0x470000},
{"soft-version", 0x7b0000, 0x00100},
{"support-list", 0x7b1000, 0x00400},
{"user-config", 0x7c0000, 0x10000},
@@ -538,8 +538,8 @@ static struct device_info boards[] = {
{"default-mac", 0x30000, 0x00020},
{"product-info", 0x31100, 0x00100},
{"signature", 0x32000, 0x00400},
- {"os-image", 0x40000, 0x200000},
- {"file-system", 0x240000, 0x570000},
+ {"os-image", 0x40000, 0x300000},
+ {"file-system", 0x340000, 0x470000},
{"soft-version", 0x7b0000, 0x00100},
{"support-list", 0x7b1000, 0x00400},
{"user-config", 0x7c0000, 0x10000},
@@ -570,8 +570,8 @@ static struct device_info boards[] = {
{"default-mac", 0x30000, 0x00020},
{"product-info", 0x31100, 0x00100},
{"signature", 0x32000, 0x00400},
- {"os-image", 0x40000, 0x200000},
- {"file-system", 0x240000, 0x570000},
+ {"os-image", 0x40000, 0x300000},
+ {"file-system", 0x340000, 0x470000},
{"soft-version", 0x7b0000, 0x00100},
{"support-list", 0x7b1000, 0x00400},
{"user-config", 0x7c0000, 0x10000},
@@ -603,8 +603,8 @@ static struct device_info boards[] = {
{"default-mac", 0x30000, 0x00020},
{"product-info", 0x31100, 0x00100},
{"signature", 0x32000, 0x00400},
- {"os-image", 0x40000, 0x200000},
- {"file-system", 0x240000, 0x570000},
+ {"os-image", 0x40000, 0x300000},
+ {"file-system", 0x340000, 0x470000},
{"soft-version", 0x7b0000, 0x00100},
{"support-list", 0x7b1000, 0x00400},
{"user-config", 0x7c0000, 0x10000},
@@ -636,8 +636,8 @@ static struct device_info boards[] = {
{"default-mac", 0x30000, 0x00020},
{"product-info", 0x31100, 0x00100},
{"signature", 0x32000, 0x00400},
- {"os-image", 0x40000, 0x200000},
- {"file-system", 0x240000, 0x570000},
+ {"os-image", 0x40000, 0x300000},
+ {"file-system", 0x340000, 0x470000},
{"soft-version", 0x7b0000, 0x00100},
{"support-list", 0x7b1000, 0x00400},
{"user-config", 0x7c0000, 0x10000},