aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/generic/config-4.141
-rw-r--r--target/linux/generic/config-4.191
-rw-r--r--target/linux/generic/config-5.41
-rw-r--r--target/linux/kirkwood/Makefile2
-rw-r--r--target/linux/kirkwood/config-5.45
5 files changed, 4 insertions, 6 deletions
diff --git a/target/linux/generic/config-4.14 b/target/linux/generic/config-4.14
index bcf47f10d1..047921b3b1 100644
--- a/target/linux/generic/config-4.14
+++ b/target/linux/generic/config-4.14
@@ -5224,6 +5224,7 @@ CONFIG_USB_DEFAULT_PERSIST=y
# CONFIG_USB_DYNAMIC_MINORS is not set
# CONFIG_USB_EG20T is not set
# CONFIG_USB_EHCI_ATH79 is not set
+# CONFIG_USB_EHCI_HCD is not set
# CONFIG_USB_EHCI_HCD_AT91 is not set
# CONFIG_USB_EHCI_HCD_OMAP is not set
# CONFIG_USB_EHCI_HCD_PPC_OF is not set
diff --git a/target/linux/generic/config-4.19 b/target/linux/generic/config-4.19
index aa0b0e0b20..172af013db 100644
--- a/target/linux/generic/config-4.19
+++ b/target/linux/generic/config-4.19
@@ -5501,6 +5501,7 @@ CONFIG_USB_DEFAULT_PERSIST=y
# CONFIG_USB_DYNAMIC_MINORS is not set
# CONFIG_USB_EG20T is not set
# CONFIG_USB_EHCI_ATH79 is not set
+# CONFIG_USB_EHCI_HCD is not set
# CONFIG_USB_EHCI_HCD_AT91 is not set
# CONFIG_USB_EHCI_HCD_OMAP is not set
# CONFIG_USB_EHCI_HCD_PPC_OF is not set
diff --git a/target/linux/generic/config-5.4 b/target/linux/generic/config-5.4
index aca72b8fae..a9d3e6920a 100644
--- a/target/linux/generic/config-5.4
+++ b/target/linux/generic/config-5.4
@@ -5873,6 +5873,7 @@ CONFIG_USB_DEFAULT_PERSIST=y
# CONFIG_USB_EG20T is not set
# CONFIG_USB_EHCI_ATH79 is not set
# CONFIG_USB_EHCI_FSL is not set
+# CONFIG_USB_EHCI_HCD is not set
# CONFIG_USB_EHCI_HCD_AT91 is not set
# CONFIG_USB_EHCI_HCD_OMAP is not set
# CONFIG_USB_EHCI_HCD_PPC_OF is not set
diff --git a/target/linux/kirkwood/Makefile b/target/linux/kirkwood/Makefile
index c5ed939d76..c50c03b548 100644
--- a/target/linux/kirkwood/Makefile
+++ b/target/linux/kirkwood/Makefile
@@ -18,6 +18,6 @@ include $(INCLUDE_DIR)/target.mk
KERNELNAME:=zImage dtbs
-DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += uboot-envtools kmod-usb2
$(eval $(call BuildTarget))
diff --git a/target/linux/kirkwood/config-5.4 b/target/linux/kirkwood/config-5.4
index da03efa94c..a04bce9635 100644
--- a/target/linux/kirkwood/config-5.4
+++ b/target/linux/kirkwood/config-5.4
@@ -342,12 +342,7 @@ CONFIG_UNWINDER_ARM=y
# CONFIG_UNWINDER_FRAME_POINTER is not set
CONFIG_USB=y
CONFIG_USB_COMMON=y
-# CONFIG_USB_EHCI_FSL is not set
-CONFIG_USB_EHCI_HCD=y
-CONFIG_USB_EHCI_HCD_ORION=y
-# CONFIG_USB_EHCI_HCD_PLATFORM is not set
CONFIG_USB_LED_TRIG=y
-CONFIG_USB_STORAGE=y
CONFIG_USB_SUPPORT=y
CONFIG_USE_OF=y
# CONFIG_VFP is not set