aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index e0f2918a38..7d124ece19 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -11,6 +11,39 @@ define Build/uImage
@mv $@.new $@
endef
+define Build/buffalo-enc
+ $(eval product=$(word 1,$(1)))
+ $(eval version=$(word 2,$(1)))
+ $(eval args=$(wordlist 3,$(words $(1)),$(1)))
+ $(STAGING_DIR_HOST)/bin/buffalo-enc \
+ -p $(product) -v $(version) $(args) \
+ -i $@ -o $@.new
+ mv $@.new $@
+endef
+
+define Build/buffalo-enc-tag
+ $(call Build/buffalo-enc,'' '' -S 152 $(1))
+endef
+
+define Build/buffalo-tag-dhp
+ $(eval product=$(word 1,$(1)))
+ $(eval region=$(word 2,$(1)))
+ $(eval language=$(word 3,$(1)))
+ $(STAGING_DIR_HOST)/bin/buffalo-tag \
+ -d 0x01000000 -w 1 \
+ -a $(BUFFALO_TAG_PLATFORM) \
+ -v $(BUFFALO_TAG_VERSION) -m $(BUFFALO_TAG_MINOR) \
+ -b $(product) -p $(product) \
+ -r $(region) -r $(region) -l $(language) \
+ -I $@ -o $@.new
+ mv $@.new $@
+endef
+
+define Build/buffalo-dhp-image
+ $(STAGING_DIR_HOST)/bin/mkdhpimg $@ $@.new
+ mv $@.new $@
+endef
+
define Build/netgear-chk
$(STAGING_DIR_HOST)/bin/mkchkimg \
-o $@.new \