aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/package/parprouted
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/parprouted')
-rw-r--r--openwrt/package/parprouted/Config.in13
-rw-r--r--openwrt/package/parprouted/Makefile42
-rwxr-xr-xopenwrt/package/parprouted/files/parprouted.default1
-rwxr-xr-xopenwrt/package/parprouted/files/parprouted.init16
-rw-r--r--openwrt/package/parprouted/ipkg/parprouted.conffiles1
-rw-r--r--openwrt/package/parprouted/ipkg/parprouted.control5
-rw-r--r--openwrt/package/parprouted/patches/parprouted.patch33
7 files changed, 0 insertions, 111 deletions
diff --git a/openwrt/package/parprouted/Config.in b/openwrt/package/parprouted/Config.in
deleted file mode 100644
index edf4760316..0000000000
--- a/openwrt/package/parprouted/Config.in
+++ /dev/null
@@ -1,13 +0,0 @@
-config BR2_PACKAGE_PARPROUTED
- prompt "parprouted........................ Proxy ARP daemon"
- tristate
- default m if CONFIG_DEVEL
- help
- parprouted is a daemon for transparent IP (Layer 3) proxy ARP bridging.
- This is useful for creation of transparent firewalls and bridging networks
- with different MAC protocols. Also, unlike standard bridging, proxy ARP
- bridging allows to bridge Ethernet networks behind wireless nodes without
- using WDS or layer 2 bridging.
-
- http://www.hazard.maks.net/
-
diff --git a/openwrt/package/parprouted/Makefile b/openwrt/package/parprouted/Makefile
deleted file mode 100644
index a06a15251d..0000000000
--- a/openwrt/package/parprouted/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=parprouted
-PKG_VERSION:=0.63
-PKG_RELEASE:=1
-PKG_MD5SUM:=12753098a22e82997d1941d6d2284750
-
-PKG_SOURCE_URL:=http://www.hazard.maks.net/parprouted/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,PARPROUTED,parprouted,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="" \
- all
- touch $@
-
-$(IPKG_PARPROUTED):
- install -d -m0755 $(IDIR_PARPROUTED)/etc/default
- install -m0755 ./files/parprouted.default $(IDIR_PARPROUTED)/etc/default/parprouted
- install -d -m0755 $(IDIR_PARPROUTED)/etc/init.d
- install -m0755 ./files/parprouted.init $(IDIR_PARPROUTED)/etc/init.d/parprouted
- ln -sf parprouted $(IDIR_PARPROUTED)/etc/init.d/S50parpouted
- install -d -m0755 $(IDIR_PARPROUTED)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/parprouted $(IDIR_PARPROUTED)/usr/sbin/
- $(RSTRIP) $(IDIR_PARPROUTED)
- $(IPKG_BUILD) $(IDIR_PARPROUTED) $(PACKAGE_DIR)
-
-mostlyclean:
- -$(MAKE) -C $(PKG_BUILD_DIR) clean
- rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/parprouted/files/parprouted.default b/openwrt/package/parprouted/files/parprouted.default
deleted file mode 100755
index 7128a56a74..0000000000
--- a/openwrt/package/parprouted/files/parprouted.default
+++ /dev/null
@@ -1 +0,0 @@
-OPTIONS="$lan_ifname $wifi_ifname"
diff --git a/openwrt/package/parprouted/files/parprouted.init b/openwrt/package/parprouted/files/parprouted.init
deleted file mode 100755
index 2422657ee8..0000000000
--- a/openwrt/package/parprouted/files/parprouted.init
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-BIN=parprouted
-DEFAULT=/etc/default/$BIN
-[ -f $DEFAULT ] && . $DEFAULT
-
-case $1 in
- start)
- $BIN $OPTIONS
- ;;
- *)
- echo "usage: $0 (start)"
- exit 1
-esac
-
-exit $?
diff --git a/openwrt/package/parprouted/ipkg/parprouted.conffiles b/openwrt/package/parprouted/ipkg/parprouted.conffiles
deleted file mode 100644
index 4446a8e997..0000000000
--- a/openwrt/package/parprouted/ipkg/parprouted.conffiles
+++ /dev/null
@@ -1 +0,0 @@
-/etc/default/parprouted
diff --git a/openwrt/package/parprouted/ipkg/parprouted.control b/openwrt/package/parprouted/ipkg/parprouted.control
deleted file mode 100644
index 9357ae5861..0000000000
--- a/openwrt/package/parprouted/ipkg/parprouted.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: parprouted
-Priority: optional
-Section: net
-Description: a proxy ARP daemon
-Depends: libpthread
diff --git a/openwrt/package/parprouted/patches/parprouted.patch b/openwrt/package/parprouted/patches/parprouted.patch
deleted file mode 100644
index 17fbdecec7..0000000000
--- a/openwrt/package/parprouted/patches/parprouted.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -rupw parprouted-0.63/arp.c parprouted-0.63-1/arp.c
---- parprouted-0.63/arp.c 2004-05-23 14:06:31.000000000 +0200
-+++ parprouted-0.63-1/arp.c 2005-03-13 16:10:18.000000000 +0100
-@@ -366,7 +366,7 @@ void *arp(char *ifname)
- do {
- pthread_testcancel();
- /* Sleep a bit in order not to overload the system */
-- usleep(300);
-+ usleep(3000);
-
- if (arp_recv(sock, &frame) <= 0)
- continue;
-diff -rupw parprouted-0.63/parprouted.c parprouted-0.63-1/parprouted.c
---- parprouted-0.63/parprouted.c 2004-01-30 02:45:43.000000000 +0100
-+++ parprouted-0.63-1/parprouted.c 2005-03-20 09:14:35.000000000 +0100
-@@ -93,7 +93,7 @@ void processarp(int cleanup)
-
- /* added route to the kernel */
- if (snprintf(routecmd_str, ROUTE_CMD_LEN-1,
-- "/sbin/ip route add %s/32 metric 50 dev %s scope link",
-+ "/sbin/route add -host %s metric 50 dev %s",
- inet_ntoa(cur_entry->ipaddr_ia), cur_entry->ifname) > ROUTE_CMD_LEN-1)
- {
- syslog(LOG_INFO, "ip route command too large to fit in buffer!");
-@@ -112,7 +112,7 @@ void processarp(int cleanup)
-
- /* remove entry from arp table and remove route from kernel */
- if (snprintf(routecmd_str, ROUTE_CMD_LEN-1,
-- "/sbin/ip route del %s/32 metric 50 dev %s scope link",
-+ "/sbin/route del -host %s metric 50 dev %s",
- inet_ntoa(cur_entry->ipaddr_ia), cur_entry->ifname) > ROUTE_CMD_LEN-1)
- {
- syslog(LOG_INFO, "ip route command too large to fit in buffer!");