aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch')
-rw-r--r--package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch b/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
deleted file mode 100644
index 89b02044dc..0000000000
--- a/package/boot/uboot-omap/patches/103-disable-fat-write-spl.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: u-boot-2017.01/fs/fat/Makefile
-===================================================================
---- u-boot-2017.01.orig/fs/fat/Makefile
-+++ u-boot-2017.01/fs/fat/Makefile
-@@ -4,8 +4,8 @@
- #
-
- obj-$(CONFIG_FS_FAT) := fat.o
--obj-$(CONFIG_FAT_WRITE):= fat_write.o
-
- ifndef CONFIG_SPL_BUILD
-+obj-$(CONFIG_FAT_WRITE):= fat_write.o
- obj-$(CONFIG_FS_FAT) += file.o
- endif
-Index: u-boot-2017.01/fs/fat/fat.c
-===================================================================
---- u-boot-2017.01.orig/fs/fat/fat.c
-+++ u-boot-2017.01/fs/fat/fat.c
-@@ -163,7 +163,7 @@ static void get_name(dir_entry *dirent,
- }
-
- static int flush_dirty_fat_buffer(fsdata *mydata);
--#if !defined(CONFIG_FAT_WRITE)
-+#if !defined(CONFIG_FAT_WRITE) || defined(CONFIG_SPL_BUILD)
- /* Stub for read only operation */
- int flush_dirty_fat_buffer(fsdata *mydata)
- {