aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-sunxi/Makefile')
-rw-r--r--package/boot/uboot-sunxi/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 321e7e9c03..f7f96e9724 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -184,6 +184,14 @@ define U-Boot/pine64_plus
UENV:=a64
endef
+define U-Boot/orangepi_zero_plus
+ BUILD_SUBTARGET:=cortexa53
+ NAME:=Xunlong Orange Pi Zero Plus
+ BUILD_DEVICES:=sun50i-h5-orangepi-zero-plus
+ DEPENDS:=+PACKAGE_u-boot-orangepi_zero_plus:arm-trusted-firmware-sunxi
+ UENV:=a64
+endef
+
UBOOT_TARGETS := \
A10-OLinuXino-Lime \
A13-OLinuXino \
@@ -210,7 +218,8 @@ UBOOT_TARGETS := \
orangepi_plus \
orangepi_2 \
pangolin \
- pine64_plus
+ pine64_plus \
+ orangepi_zero_plus
UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes