aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-sunxi
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-sunxi')
-rw-r--r--package/boot/uboot-sunxi/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 58a5923eab..859a06019b 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -226,6 +226,14 @@ define U-Boot/pangolin
UENV:=pangolin
endef
+define U-Boot/libretech_all_h3_cc_h5
+ BUILD_SUBTARGET:=cortexa53
+ NAME:=Libre Computer ALL-H3-CC H5
+ BUILD_DEVICES:=libretech_all-h3-cc-h5
+ DEPENDS:=+PACKAGE_u-boot-libretech_all_h3_cc_h5:arm-trusted-firmware-sunxi
+ UENV:=a64
+endef
+
define U-Boot/nanopi_neo_plus2
BUILD_SUBTARGET:=cortexa53
NAME:=NanoPi NEO Plus2 (H5)
@@ -328,7 +336,8 @@ UBOOT_TARGETS := \
pangolin \
pine64_plus \
sopine_baseboard \
- orangepi_zero_plus
+ orangepi_zero_plus \
+ libretech_all_h3_cc_h5
UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes