aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-atm
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/lantiq/ltq-atm')
-rw-r--r--package/kernel/lantiq/ltq-atm/Makefile2
-rw-r--r--package/kernel/lantiq/ltq-atm/src/ltq_atm.c8
2 files changed, 1 insertions, 9 deletions
diff --git a/package/kernel/lantiq/ltq-atm/Makefile b/package/kernel/lantiq/ltq-atm/Makefile
index 455d7b25e3..89a3328cf8 100644
--- a/package/kernel/lantiq/ltq-atm/Makefile
+++ b/package/kernel/lantiq/ltq-atm/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ltq-atm
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
PKG_LICENSE:=GPL-2.0+
diff --git a/package/kernel/lantiq/ltq-atm/src/ltq_atm.c b/package/kernel/lantiq/ltq-atm/src/ltq_atm.c
index f5dbfaae2d..55362a5c7b 100644
--- a/package/kernel/lantiq/ltq-atm/src/ltq_atm.c
+++ b/package/kernel/lantiq/ltq-atm/src/ltq_atm.c
@@ -289,17 +289,9 @@ static int ppe_ioctl(struct atm_dev *dev, unsigned int cmd, void *arg)
return -ENOTTY;
if ( _IOC_DIR(cmd) & _IOC_READ )
-#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,0,0)
ret = !access_ok(arg, _IOC_SIZE(cmd));
-#else
- ret = !access_ok(VERIFY_WRITE, arg, _IOC_SIZE(cmd));
-#endif
else if ( _IOC_DIR(cmd) & _IOC_WRITE )
-#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,0,0)
ret = !access_ok(arg, _IOC_SIZE(cmd));
-#else
- ret = !access_ok(VERIFY_READ, arg, _IOC_SIZE(cmd));
-#endif
if ( ret )
return -EFAULT;