aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netdevices.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/netdevices.mk')
-rw-r--r--package/kernel/linux/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 81b23f98df..012017425a 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -107,6 +107,22 @@ endef
$(eval $(call KernelPackage,libphy))
+
+define KernelPackage/phylink
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Model for MAC to optional PHY connection
+ KCONFIG:=CONFIG_PHYLINK
+ FILES:=$(LINUX_DIR)/drivers/net/phy/phylink.ko
+ AUTOLOAD:=$(call AutoLoad,15,phylink,1)
+endef
+
+define KernelPackage/phylink/description
+ Model for MAC to optional PHY connection
+endef
+
+$(eval $(call KernelPackage,phylink))
+
+
define KernelPackage/mii
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=MII library