aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/pcre/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/pcre/Makefile')
-rw-r--r--package/libs/pcre/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/libs/pcre/Makefile b/package/libs/pcre/Makefile
index b638c876da..3655614169 100644
--- a/package/libs/pcre/Makefile
+++ b/package/libs/pcre/Makefile
@@ -61,6 +61,18 @@ define Package/libpcrecpp
DEPENDS:=+libpcre $(CXX_DEPENDS)
endef
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --enable-utf8 \
+ --enable-unicode-properties \
+ --enable-pcre16 \
+ --with-match-limit-recursion=16000 \
+ --enable-cpp
+
+$(eval $(call HostBuild))
+
+
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \