aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/ltq-vdsl-app/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/config/ltq-vdsl-app/Makefile')
-rw-r--r--package/network/config/ltq-vdsl-app/Makefile26
1 files changed, 9 insertions, 17 deletions
diff --git a/package/network/config/ltq-vdsl-app/Makefile b/package/network/config/ltq-vdsl-app/Makefile
index b069421596..51c2aff9a1 100644
--- a/package/network/config/ltq-vdsl-app/Makefile
+++ b/package/network/config/ltq-vdsl-app/Makefile
@@ -1,4 +1,5 @@
# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2015 Lantiq Beteiligungs GmbH & Co KG.
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,12 +8,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ltq-vdsl-app
-PKG_VERSION:=4.16.2.4
+PKG_VERSION:=4.16.6.3
PKG_RELEASE:=1
-PKG_BASE_NAME:=dsl_cpe_control_vrx
-PKG_SOURCE:=$(PKG_BASE_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/xdarklight/$(PKG_BASE_NAME)/archive/v$(PKG_VERSION)
-PKG_MD5SUM:=487925ef5327ea38c544035b388de8bb
+PKG_BASE_NAME:=dsl_cpe_control
+PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_MD5SUM:=8bedf330a456fe0864844e61b57da627
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
PKG_LICENSE:=BSD-2-Clause
@@ -39,21 +40,12 @@ CONFIGURE_ARGS += \
--enable-vrx \
--enable-driver-include="-I$(STAGING_DIR)/usr/include/drv_vdsl_cpe_api" \
--enable-device-driver-include="-I$(STAGING_DIR)/usr/include/vdsl/" \
- --enable-add-appl-cflags="-DMAX_CLI_PIPES=2" \
+ --enable-add-appl-cflags="-DMAX_CLI_PIPES=1" \
--enable-ifxos \
--enable-ifxos-include="-I$(STAGING_DIR)/usr/include/ifxos" \
--enable-ifxos-library="-I$(STAGING_DIR)/usr/lib" \
- --disable-dsl-ceoc \
- --enable-dsl-pm-total \
- --enable-dsl-pm-showtime \
- --enable-dsl-pm-line-counters \
- --enable-dsl-pm-line-failure-counters \
- --enable-dsl-pm-datapath-counters \
- --enable-dsl-pm-datapath-failure-counters \
- --enable-deprecated \
- --disable-soap-support \
- --enable-dsl-bonding=no \
- --enable-debug-prints=err \
+ --enable-dsl-ceoc=no \
+ --enable-vrx-device=vr9 \
--disable-dti \
--enable-debug