aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/6rd
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/ipv6/6rd')
-rw-r--r--package/network/ipv6/6rd/Makefile2
-rw-r--r--package/network/ipv6/6rd/files/6rd.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/ipv6/6rd/Makefile b/package/network/ipv6/6rd/Makefile
index 5086fae69d..47f20414fc 100644
--- a/package/network/ipv6/6rd/Makefile
+++ b/package/network/ipv6/6rd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=6rd
PKG_VERSION:=9
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6rd/files/6rd.sh b/package/network/ipv6/6rd/files/6rd.sh
index 8b34414280..62a20314d9 100644
--- a/package/network/ipv6/6rd/files/6rd.sh
+++ b/package/network/ipv6/6rd/files/6rd.sh
@@ -40,8 +40,8 @@ proto_6rd_setup() {
# Determine the relay prefix.
local ip4prefixlen="${ip4prefixlen:-0}"
- local ip4prefix=$(ipcalc.sh "$ipaddr/$ip4prefixlen" | grep NETWORK)
- ip4prefix="${ip4prefix#NETWORK=}"
+ local ip4prefix
+ eval "$(ipcalc.sh "$ipaddr/$ip4prefixlen")";ip4prefix=$NETWORK
# Determine our IPv6 address.
local ip6subnet=$(6rdcalc "$ip6prefix/$ip6prefixlen" "$ipaddr/$ip4prefixlen")