aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/curl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/curl/Makefile')
-rw-r--r--package/network/utils/curl/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index fdb8533ae9..c483ec1186 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -64,7 +64,11 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_LIBCURL_TLS_SRP \
CONFIG_LIBCURL_UNIX_SOCKETS \
CONFIG_LIBCURL_VERBOSE \
- CONFIG_LIBCURL_NTLM
+ CONFIG_LIBCURL_NTLM \
+ $(if $(CONFIG_LIBCURL_OPENSSL), \
+ CONFIG_OPENSSL_ENGINE \
+ CONFIG_OPENSSL_WITH_COMPRESSION \
+ CONFIG_OPENSSL_WITH_NPN)
include $(INCLUDE_DIR)/package.mk