aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/patches/170-ip_tiny.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/iproute2/patches/170-ip_tiny.patch')
-rw-r--r--package/network/utils/iproute2/patches/170-ip_tiny.patch20
1 files changed, 1 insertions, 19 deletions
diff --git a/package/network/utils/iproute2/patches/170-ip_tiny.patch b/package/network/utils/iproute2/patches/170-ip_tiny.patch
index 91240b6d2f..fb5a6466e4 100644
--- a/package/network/utils/iproute2/patches/170-ip_tiny.patch
+++ b/package/network/utils/iproute2/patches/170-ip_tiny.patch
@@ -41,7 +41,7 @@
+#endif
" OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
" -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
- " -f[amily] { inet | inet6 | ipx | dnet | mpls | bridge | link } |\n"
+ " -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
@@ -72,32 +78,44 @@ static const struct cmd {
int (*func)(int argc, char **argv);
} cmds[] = {
@@ -87,24 +87,6 @@
{ "vrf", do_ipvrf},
{ "sr", do_seg6 },
{ "help", do_help },
---- a/lib/utils.c
-+++ b/lib/utils.c
-@@ -1000,6 +1000,7 @@ const char *rt_addr_n2a_r(int af, int le
- return inet_ntop(af, addr, buf, buflen);
- case AF_MPLS:
- return mpls_ntop(af, addr, buf, buflen);
-+#ifndef IPROUTE2_TINY
- case AF_IPX:
- return ipx_ntop(af, addr, buf, buflen);
- case AF_DECnet:
-@@ -1009,6 +1010,7 @@ const char *rt_addr_n2a_r(int af, int le
- memcpy(dna.a_addr, addr, 2);
- return dnet_ntop(af, &dna, buf, buflen);
- }
-+#endif
- case AF_PACKET:
- return ll_addr_n2a(addr, len, ARPHRD_VOID, buf, buflen);
- case AF_BRIDGE:
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -3,6 +3,10 @@ include ../config.mk