aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/iproute2/Makefile6
-rw-r--r--package/network/utils/iputils/Makefile2
2 files changed, 3 insertions, 5 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 56d2897e2a..a2dae6d61b 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -82,10 +82,8 @@ define Build/Configure
> $(PKG_BUILD_DIR)/include/SNAPSHOT.h
endef
-ifdef CONFIG_USE_EGLIBC
- ifndef CONFIG_EGLIBC_VERSION_2_13
- TARGET_CFLAGS += -DHAVE_SETNS
- endif
+ifdef CONFIG_USE_GLIBC
+ TARGET_CFLAGS += -DHAVE_SETNS
endif
ifdef CONFIG_USE_MUSL
TARGET_CFLAGS += -DHAVE_SETNS
diff --git a/package/network/utils/iputils/Makefile b/package/network/utils/iputils/Makefile
index 1dc993cb81..8d7b84d6b5 100644
--- a/package/network/utils/iputils/Makefile
+++ b/package/network/utils/iputils/Makefile
@@ -68,7 +68,7 @@ endef
define Package/iputils-ping6
$(call Package/iputils/Default)
TITLE:=iputils - ping6
- DEPENDS+= @IPV6 +USE_EGLIBC:libopenssl
+ DEPENDS+= @IPV6 +USE_GLIBC:libopenssl
endef
define Package/iputils-ping6/description