aboutsummaryrefslogtreecommitdiffstats
path: root/package/rt2x00/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/rt2x00/src/Makefile')
-rw-r--r--package/rt2x00/src/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/rt2x00/src/Makefile b/package/rt2x00/src/Makefile
new file mode 100644
index 0000000000..4f3304f9a8
--- /dev/null
+++ b/package/rt2x00/src/Makefile
@@ -0,0 +1,11 @@
+rt2x00lib-objs := rt2x00dev.o rt2x00mac.o
+
+EXTRA_CFLAGS += -DCONFIG_RT2X00_LIB_FIRMWARE
+
+obj-m += rt2x00lib.o rt2x00pci.o rt2x00usb.o
+
+obj-$(CONFIG_RT2400PCI) += rt2400pci.o
+obj-$(CONFIG_RT2500PCI) += rt2500pci.o
+obj-$(CONFIG_RT61PCI) += rt61pci.o
+obj-$(CONFIG_RT2500USB) += rt2500usb.o
+obj-$(CONFIG_RT73USB) += rt73usb.o