aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/procd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/system/procd/Makefile')
-rw-r--r--package/system/procd/Makefile23
1 files changed, 19 insertions, 4 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index adc8933e0f..52c181c8f7 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -1,14 +1,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2014-06-06
+PKG_VERSION:=2014-06-10
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=53c1ea6b9ade10eff3cec07519db862b365a4233
+PKG_SOURCE_VERSION:=b76eda6cd8ba061f49af4074838e6a42ae94144c
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -25,12 +25,19 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
define Package/procd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox +libubus
+ DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand
+ TITLE:=OpenWrt system process manager
+endef
+
+define Package/procd-nand
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=@NAND_SUPPORT +ubi-utils
TITLE:=OpenWrt system process manager
endef
define Package/procd/install
- $(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions
+ $(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/{init,procd,askfirst,udevtrigger} $(1)/sbin/
$(INSTALL_BIN) ./files/reload_config $(1)/sbin/
@@ -38,4 +45,12 @@ define Package/procd/install
$(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
endef
+define Package/procd-nand/install
+ $(INSTALL_DIR) $(1)/sbin $(1)/lib/upgrade
+
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/upgraded $(1)/sbin/
+ $(INSTALL_DATA) ./files/nand.sh $(1)/lib/upgrade/
+endef
+
$(eval $(call BuildPackage,procd))
+$(eval $(call BuildPackage,procd-nand))