aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/network/services/samba36/Makefile2
-rw-r--r--package/network/services/samba36/files/samba.hotplug12
2 files changed, 10 insertions, 4 deletions
diff --git a/package/network/services/samba36/Makefile b/package/network/services/samba36/Makefile
index a4392f62c5..161f6b45aa 100644
--- a/package/network/services/samba36/Makefile
+++ b/package/network/services/samba36/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=samba
PKG_VERSION:=3.6.25
-PKG_RELEASE:=14
+PKG_RELEASE:=15
PKG_SOURCE_URL:=https://download.samba.org/pub/samba \
https://download.samba.org/pub/samba/stable
diff --git a/package/network/services/samba36/files/samba.hotplug b/package/network/services/samba36/files/samba.hotplug
index e1ae64e655..abb4346af0 100644
--- a/package/network/services/samba36/files/samba.hotplug
+++ b/package/network/services/samba36/files/samba.hotplug
@@ -6,7 +6,7 @@ device_get_vars() {
json_init
json_load "$(ubus call block info)"
- json_select devices
+ json_select devices || return 1
json_get_keys keys
for key in $keys
@@ -18,13 +18,16 @@ device_get_vars() {
shift
json_get_vars $@
json_select ..
- break
+ json_select ..
+ return 0
}
json_select ..
done
json_select ..
+
+ return 2
}
[ -f /var/run/config/samba ] || {
@@ -32,7 +35,10 @@ device_get_vars() {
}
[ "$ACTION" = "add" ] && {
- device_get_vars $DEVICE label mount
+ device_get_vars $DEVICE label mount || {
+ logger -t samba-hotplug "Failed to get $DEVICE info"
+ exit 1
+ }
[ -n "$mount" ] && {
uci -c /var/run/config batch <<-EOF
set samba.$DEVICE="sambashare"