aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amcc-2.6/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/amcc-2.6/image/Makefile')
-rw-r--r--target/linux/amcc-2.6/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/amcc-2.6/image/Makefile b/target/linux/amcc-2.6/image/Makefile
index bab2e647ee..bd391f02f2 100644
--- a/target/linux/amcc-2.6/image/Makefile
+++ b/target/linux/amcc-2.6/image/Makefile
@@ -19,6 +19,13 @@ define Image/Build
$(call Image/Build/$(1),$(1))
endef
+define Image/Build/jffs2-256k
+ ( \
+ dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=4096k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-jffs2.img
+endef
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
( \