aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk23
1 files changed, 18 insertions, 5 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index c347bd1cf1..710ab54772 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -110,15 +110,28 @@ define Device/ubnt-xw
UBNT_VERSION := 6.0.4
endef
-define Device/ubnt_aircube-isp
+define Device/ubnt-acb
$(Device/ubnt)
- SOC := qca9533
- DEVICE_MODEL := airCube ISP
IMAGE_SIZE := 15744k
- UBNT_BOARD := ACB-ISP
- UBNT_CHIP := qca9533
+ UBNT_BOARD := ACB
UBNT_TYPE := ACB
UBNT_VERSION := 2.5.0
+endef
+
+define Device/ubnt_aircube-ac
+ $(Device/ubnt-acb)
+ SOC := ar9342
+ DEVICE_MODEL := airCube AC
+ UBNT_CHIP := ar9342
+ DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += ubnt_aircube-ac
+
+define Device/ubnt_aircube-isp
+ $(Device/ubnt-acb)
+ SOC := qca9533
+ DEVICE_MODEL := airCube ISP
+ UBNT_CHIP := qca9533
SUPPORTED_DEVICES += ubnt,acb-isp
endef
TARGET_DEVICES += ubnt_aircube-isp