aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image')
-rw-r--r--target/linux/ath79/image/generic.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index c43d396db5..d11cc28146 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1309,6 +1309,23 @@ define Device/librerouter_librerouter-v1
endef
TARGET_DEVICES += librerouter_librerouter-v1
+define Device/meraki_mr12
+ SOC := ar7242
+ DEVICE_VENDOR := Meraki
+ DEVICE_MODEL := MR12
+ IMAGE_SIZE := 15616k
+ DEVICE_PACKAGES := kmod-owl-loader rssileds
+ SUPPORTED_DEVICES += mr12
+ DEVICE_COMPAT_VERSION := 2.0
+ DEVICE_COMPAT_MESSAGE := Partitions differ from ar71xx version of MR12. Image format is incompatible. \
+ To use sysupgrade, you must change /lib/update/common.sh::get_image to prepend 128K zeroes to this image, \
+ and change the bootcmd in u-boot to "bootm 0xbf0a0000". After that, you can use "sysupgrade -F -n". \
+ Make sure you do not keep your old config, as ethernet setup is not compatible either. \
+ For more details, see the OpenWrt Wiki: https://openwrt.org/toh/meraki/MR12, \
+ or the commit message of the MR12 ath79 port on git.openwrt.org.
+endef
+TARGET_DEVICES += meraki_mr12
+
define Device/meraki_mr16
SOC := ar7161
DEVICE_VENDOR := Meraki