aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/patches-4.19/440-mtd-ar934x-nand-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/patches-4.19/440-mtd-ar934x-nand-driver.patch')
-rw-r--r--target/linux/ath79/patches-4.19/440-mtd-ar934x-nand-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ath79/patches-4.19/440-mtd-ar934x-nand-driver.patch b/target/linux/ath79/patches-4.19/440-mtd-ar934x-nand-driver.patch
new file mode 100644
index 0000000000..b74ad90745
--- /dev/null
+++ b/target/linux/ath79/patches-4.19/440-mtd-ar934x-nand-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/nand/raw/Kconfig
++++ b/drivers/mtd/nand/raw/Kconfig
+@@ -561,4 +561,12 @@ config MTD_NAND_TEGRA
+ is supported. Extra OOB bytes when using HW ECC are currently
+ not supported.
+
++config MTD_NAND_AR934X
++ tristate "Support for NAND controller on Qualcomm Atheros AR934x/QCA955x SoCs"
++ depends on ATH79 || COMPILE_TEST
++ depends on HAS_IOMEM
++ help
++ Enables support for NAND controller on Qualcomm Atheros SoCs.
++ This controller is found on AR934x and QCA955x SoCs.
++
+ endif # MTD_NAND
+--- a/drivers/mtd/nand/raw/Makefile
++++ b/drivers/mtd/nand/raw/Makefile
+@@ -57,6 +57,7 @@ obj-$(CONFIG_MTD_NAND_BRCMNAND) += brcm
+ obj-$(CONFIG_MTD_NAND_QCOM) += qcom_nandc.o
+ obj-$(CONFIG_MTD_NAND_MTK) += mtk_ecc.o mtk_nand.o
+ obj-$(CONFIG_MTD_NAND_TEGRA) += tegra_nand.o
++obj-$(CONFIG_MTD_NAND_AR934X) += ar934x_nand.o
+
+ nand-objs := nand_base.o nand_bbt.o nand_timings.o nand_ids.o
+ nand-objs += nand_amd.o