aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79')
-rw-r--r--target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v2.dts8
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/01_leds1
-rw-r--r--target/linux/ath79/generic/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ath79/image/generic.mk9
4 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v2.dts b/target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v2.dts
new file mode 100644
index 0000000000..819a6be97f
--- /dev/null
+++ b/target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v2.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9341_openmesh_om2p-hs.dtsi"
+
+/ {
+ compatible = "openmesh,om2p-hs-v2", "qca,ar9341";
+ model = "OpenMesh OM2P-HS v2";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 057bec3bc8..8926ffc0c8 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -146,6 +146,7 @@ comfast,cf-e560ac)
;;
comfast,cf-ew72|\
openmesh,om2p-hs-v1|\
+openmesh,om2p-hs-v2|\
telco,t1)
ucidef_set_led_switch "lan" "LAN" "blue:lan" "switch0" "0x02"
ucidef_set_led_netdev "wan" "WAN" "blue:wan" "eth1"
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
index e3298cfc13..73c328173a 100644
--- a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
@@ -52,6 +52,7 @@ platform_do_upgrade() {
;;
openmesh,om2p-v4|\
openmesh,om2p-hs-v1|\
+ openmesh,om2p-hs-v2|\
openmesh,om2p-hs-v4)
PART_NAME="inactive"
platform_do_upgrade_openmesh "$1"
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 1454c14e44..4e80ac8402 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1586,6 +1586,15 @@ define Device/openmesh_om2p-hs-v1
endef
TARGET_DEVICES += openmesh_om2p-hs-v1
+define Device/openmesh_om2p-hs-v2
+ $(Device/openmesh_om2p-common)
+ SOC := ar9341
+ DEVICE_MODEL := OM2P-HS
+ DEVICE_VARIANT := v2
+ SUPPORTED_DEVICES += om2p-hsv2
+endef
+TARGET_DEVICES += openmesh_om2p-hs-v2
+
define Device/openmesh_om2p-hs-v4
$(Device/openmesh_om2p-common)
SOC := qca9533