aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm27xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm27xx/image/Makefile')
-rw-r--r--target/linux/bcm27xx/image/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/target/linux/bcm27xx/image/Makefile b/target/linux/bcm27xx/image/Makefile
index fbef5ecbf4..30b3e83cf6 100644
--- a/target/linux/bcm27xx/image/Makefile
+++ b/target/linux/bcm27xx/image/Makefile
@@ -90,19 +90,19 @@ define Device/rpi-2
DEVICE_ALT0_MODEL := 3B/3B+/3CM
DEVICE_ALT0_VARIANT := (32bit)
DEVICE_ALT1_VENDOR := Raspberry Pi
- DEVICE_ALT1_MODEL := 4B
+ DEVICE_ALT1_MODEL := 4B/400/4CM
DEVICE_ALT1_VARIANT := (32bit)
DEVICE_DTS := \
bcm2709-rpi-2-b bcm2710-rpi-2-b \
bcm2710-rpi-3-b bcm2710-rpi-3-b-plus \
- bcm2711-rpi-4-b \
- bcm2710-rpi-cm3
+ bcm2711-rpi-4-b bcm2711-rpi-400 \
+ bcm2710-rpi-cm3 bcm2711-rpi-cm4
SUPPORTED_DEVICES := \
rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm \
raspberrypi,2-model-b raspberrypi,2-model-b-rev2 \
raspberrypi,3-model-b raspberrypi,3-model-b-plus \
raspberrypi,3-compute-module raspberrypi,compute-module-3 \
- raspberrypi,4-model-b
+ raspberrypi,400 raspberrypi,4-compute-module raspberrypi,4-model-b
DEVICE_PACKAGES := \
cypress-firmware-43430-sdio \
cypress-nvram-43430-sdio-rpi-3b \
@@ -144,11 +144,16 @@ ifeq ($(SUBTARGET),bcm2710)
endif
define Device/rpi-4
- DEVICE_MODEL := 4B
+ DEVICE_MODEL := 4B/400/4CM
DEVICE_VARIANT := (64bit)
KERNEL_IMG := kernel8.img
- DEVICE_DTS := broadcom/bcm2711-rpi-4-b
+ DEVICE_DTS := \
+ broadcom/bcm2711-rpi-400 \
+ broadcom/bcm2711-rpi-4-b \
+ broadcom/bcm2711-rpi-cm4
SUPPORTED_DEVICES := \
+ raspberrypi,400 \
+ raspberrypi,4-compute-module \
raspberrypi,4-model-b
DEVICE_PACKAGES := \
cypress-firmware-43455-sdio \