aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm63xx/image/Makefile')
-rw-r--r--target/linux/brcm63xx/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 1cf64bd8e7..cc1660aa25 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -161,6 +161,8 @@ define Device/Default
KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
KERNEL_INITRAMFS_SUFFIX := .elf
DEVICE_DTS_DIR := ../dts
+ SOC = bcm$$(CFE_CHIP_ID)
+ DEVICE_DTS = $$(SOC)-$(subst _,-,$(1))
endef
ATH5K_PACKAGES := kmod-ath5k wpad-basic