aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-4.9/904-debloat_dma_buf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/hack-4.9/904-debloat_dma_buf.patch')
-rw-r--r--target/linux/generic/hack-4.9/904-debloat_dma_buf.patch13
1 files changed, 1 insertions, 12 deletions
diff --git a/target/linux/generic/hack-4.9/904-debloat_dma_buf.patch b/target/linux/generic/hack-4.9/904-debloat_dma_buf.patch
index 947471ae78..4f432c3568 100644
--- a/target/linux/generic/hack-4.9/904-debloat_dma_buf.patch
+++ b/target/linux/generic/hack-4.9/904-debloat_dma_buf.patch
@@ -11,8 +11,6 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
kernel/sched/core.c | 1 +
4 files changed, 12 insertions(+), 5 deletions(-)
-diff --git a/drivers/base/Kconfig b/drivers/base/Kconfig
-index d02e7c0f5bfd..e1c0e2e0d3a8 100644
--- a/drivers/base/Kconfig
+++ b/drivers/base/Kconfig
@@ -241,7 +241,7 @@ config SOC_BUS
@@ -24,8 +22,6 @@ index d02e7c0f5bfd..e1c0e2e0d3a8 100644
default n
select ANON_INODES
help
-diff --git a/drivers/dma-buf/Makefile b/drivers/dma-buf/Makefile
-index 210a10bfad2b..36ee68dcdffe 100644
--- a/drivers/dma-buf/Makefile
+++ b/drivers/dma-buf/Makefile
@@ -1,3 +1,7 @@
@@ -39,8 +35,6 @@ index 210a10bfad2b..36ee68dcdffe 100644
+dma-buf-objs-$(CONFIG_SW_SYNC) += sw_sync.o sync_debug.o
+
+dma-shared-buffer-objs := $(dma-buf-objs-y)
-diff --git a/drivers/dma-buf/dma-buf.c b/drivers/dma-buf/dma-buf.c
-index 6b54e02da10c..24e69ef1f243 100644
--- a/drivers/dma-buf/dma-buf.c
+++ b/drivers/dma-buf/dma-buf.c
@@ -34,6 +34,7 @@
@@ -58,11 +52,9 @@ index 6b54e02da10c..24e69ef1f243 100644
-__exitcall(dma_buf_deinit);
+module_exit(dma_buf_deinit);
+MODULE_LICENSE("GPL");
-diff --git a/kernel/sched/core.c b/kernel/sched/core.c
-index 692c948ae333..eaf379285cca 100644
--- a/kernel/sched/core.c
+++ b/kernel/sched/core.c
-@@ -2170,6 +2170,7 @@ int wake_up_state(struct task_struct *p, unsigned int state)
+@@ -2170,6 +2170,7 @@ int wake_up_state(struct task_struct *p,
{
return try_to_wake_up(p, state, 0);
}
@@ -70,6 +62,3 @@ index 692c948ae333..eaf379285cca 100644
/*
* This function clears the sched_dl_entity static params.
---
-2.11.0
-