aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/image')
-rw-r--r--target/linux/generic/image/relocate/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/generic/image/relocate/Makefile b/target/linux/generic/image/relocate/Makefile
index 500423b63b..5f6ebeb096 100644
--- a/target/linux/generic/image/relocate/Makefile
+++ b/target/linux/generic/image/relocate/Makefile
@@ -22,6 +22,7 @@ BOARD :=
FLASH_OFFS :=
FLASH_MAX :=
PLATFORM :=
+CACHELINE_SIZE := 32
CC := $(CROSS_COMPILE)gcc
LD := $(CROSS_COMPILE)ld
@@ -36,7 +37,8 @@ CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-common -ffreestanding -fhonour-copts \
-mabi=32 -march=mips32r2 \
-Wa,-32 -Wa,-march=mips32r2 -Wa,-mips32r2 -Wa,--trap \
- -DCONFIG_CACHELINE_SIZE=32 -DKERNEL_ADDR=$(KERNEL_ADDR)
+ -DCONFIG_CACHELINE_SIZE=$(CACHELINE_SIZE) \
+ -DKERNEL_ADDR=$(KERNEL_ADDR)
ASFLAGS = $(CFLAGS) -D__ASSEMBLY__