aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 578303e9e0..5cc66daa21 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -109,6 +109,23 @@ define Device/compex_wpq864
endef
TARGET_DEVICES += compex_wpq864
+define Device/linksys_ea7500-v1
+ $(call Device/LegacyImage)
+ DEVICE_VENDOR := Linksys
+ DEVICE_MODEL := EA7500
+ DEVICE_VARIANT := v1
+ SOC := qcom-ipq8064
+ PAGESIZE := 2048
+ BLOCKSIZE := 128k
+ KERNEL_SIZE := 3072k
+ KERNEL = kernel-bin | append-dtb | uImage none | append-uImage-fakehdr filesystem
+ UBINIZE_OPTS := -E 5
+ IMAGES := factory.bin sysupgrade.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
+endef
+TARGET_DEVICES += linksys_ea7500-v1
+
define Device/linksys_ea8500
$(call Device/LegacyImage)
DEVICE_VENDOR := Linksys