aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 3b86760a19..ec73630ae5 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -109,6 +109,19 @@ define Device/compex_wpq864
endef
TARGET_DEVICES += compex_wpq864
+define Device/edgecore_ecw5410
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ DEVICE_VENDOR := Edgecore
+ DEVICE_MODEL := ECW5410
+ SOC := qcom-ipq8068
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ DEVICE_DTS_CONFIG := config@v2.0-ap160
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ipq-wifi-edgecore_ecw5410
+endef
+TARGET_DEVICES += edgecore_ecw5410
+
define Device/linksys_ea7500-v1
$(call Device/LegacyImage)
DEVICE_VENDOR := Linksys
@@ -126,18 +139,6 @@ define Device/linksys_ea7500-v1
endef
TARGET_DEVICES += linksys_ea7500-v1
-define Device/edgecore_ecw5410
- $(call Device/FitImage)
- $(call Device/UbiFit)
- DEVICE_TITLE := Edgecore ECW5410
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- DEVICE_DTS := qcom-ipq8068-ecw5410
- DEVICE_DTS_CONFIG := config@v2.0-ap160
- DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ipq-wifi-edgecore_ecw5410
-endef
-TARGET_DEVICES += edgecore_ecw5410
-
define Device/linksys_ea8500
$(call Device/LegacyImage)
DEVICE_VENDOR := Linksys