aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/patches-2.6.25/030-ixp4xx_fsg_board_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ixp4xx/patches-2.6.25/030-ixp4xx_fsg_board_support.patch')
-rw-r--r--target/linux/ixp4xx/patches-2.6.25/030-ixp4xx_fsg_board_support.patch42
1 files changed, 21 insertions, 21 deletions
diff --git a/target/linux/ixp4xx/patches-2.6.25/030-ixp4xx_fsg_board_support.patch b/target/linux/ixp4xx/patches-2.6.25/030-ixp4xx_fsg_board_support.patch
index 5a2fb4ca03..ddbb8a4312 100644
--- a/target/linux/ixp4xx/patches-2.6.25/030-ixp4xx_fsg_board_support.patch
+++ b/target/linux/ixp4xx/patches-2.6.25/030-ixp4xx_fsg_board_support.patch
@@ -45,10 +45,10 @@ now calls machine_restart() directly.
create mode 100644 arch/arm/mach-ixp4xx/fsg-setup.c
create mode 100644 include/asm-arm/arch-ixp4xx/fsg.h
-Index: linux-2.6.25.1/arch/arm/configs/ixp4xx_defconfig
+Index: linux-2.6.25.4/arch/arm/configs/ixp4xx_defconfig
===================================================================
---- linux-2.6.25.1.orig/arch/arm/configs/ixp4xx_defconfig
-+++ linux-2.6.25.1/arch/arm/configs/ixp4xx_defconfig
+--- linux-2.6.25.4.orig/arch/arm/configs/ixp4xx_defconfig
++++ linux-2.6.25.4/arch/arm/configs/ixp4xx_defconfig
@@ -165,6 +165,7 @@ CONFIG_ARCH_PRPMC1100=y
CONFIG_MACH_NAS100D=y
CONFIG_MACH_DSMG600=y
@@ -94,10 +94,10 @@ Index: linux-2.6.25.1/arch/arm/configs/ixp4xx_defconfig
CONFIG_RTC_DRV_X1205=y
CONFIG_RTC_DRV_PCF8563=y
# CONFIG_RTC_DRV_PCF8583 is not set
-Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/Kconfig
+Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
===================================================================
---- linux-2.6.25.1.orig/arch/arm/mach-ixp4xx/Kconfig
-+++ linux-2.6.25.1/arch/arm/mach-ixp4xx/Kconfig
+--- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Kconfig
++++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
@@ -125,6 +125,15 @@ config ARCH_IXDP4XX
depends on ARCH_IXDP425 || MACH_IXDP465 || MACH_KIXRP435
default y
@@ -114,10 +114,10 @@ Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/Kconfig
#
# Certain registers and IRQs are only enabled if supporting IXP465 CPUs
#
-Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/Makefile
+Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
===================================================================
---- linux-2.6.25.1.orig/arch/arm/mach-ixp4xx/Makefile
-+++ linux-2.6.25.1/arch/arm/mach-ixp4xx/Makefile
+--- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Makefile
++++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
@@ -15,6 +15,7 @@ obj-pci-$(CONFIG_MACH_NAS100D) += nas10
obj-pci-$(CONFIG_MACH_DSMG600) += dsmg600-pci.o
obj-pci-$(CONFIG_MACH_GATEWAY7001) += gateway7001-pci.o
@@ -134,10 +134,10 @@ Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/Makefile
obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o
obj-$(CONFIG_IXP4XX_QMGR) += ixp4xx_qmgr.o
-Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/fsg-pci.c
+Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/fsg-pci.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/arch/arm/mach-ixp4xx/fsg-pci.c
++++ linux-2.6.25.4/arch/arm/mach-ixp4xx/fsg-pci.c
@@ -0,0 +1,71 @@
+/*
+ * arch/arch/mach-ixp4xx/fsg-pci.c
@@ -210,10 +210,10 @@ Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/fsg-pci.c
+}
+
+subsys_initcall(fsg_pci_init);
-Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/fsg-setup.c
+Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/fsg-setup.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/arch/arm/mach-ixp4xx/fsg-setup.c
++++ linux-2.6.25.4/arch/arm/mach-ixp4xx/fsg-setup.c
@@ -0,0 +1,276 @@
+/*
+ * arch/arm/mach-ixp4xx/fsg-setup.c
@@ -491,10 +491,10 @@ Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/fsg-setup.c
+ .init_machine = fsg_init,
+MACHINE_END
+
-Index: linux-2.6.25.1/include/asm-arm/arch-ixp4xx/fsg.h
+Index: linux-2.6.25.4/include/asm-arm/arch-ixp4xx/fsg.h
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/include/asm-arm/arch-ixp4xx/fsg.h
++++ linux-2.6.25.4/include/asm-arm/arch-ixp4xx/fsg.h
@@ -0,0 +1,50 @@
+/*
+ * include/asm-arm/arch-ixp4xx/fsg.h
@@ -546,10 +546,10 @@ Index: linux-2.6.25.1/include/asm-arm/arch-ixp4xx/fsg.h
+#define FSG_LED_USB_BIT 4
+#define FSG_LED_RING_BIT 5
+#define FSG_LED_SYNC_BIT 7
-Index: linux-2.6.25.1/include/asm-arm/arch-ixp4xx/hardware.h
+Index: linux-2.6.25.4/include/asm-arm/arch-ixp4xx/hardware.h
===================================================================
---- linux-2.6.25.1.orig/include/asm-arm/arch-ixp4xx/hardware.h
-+++ linux-2.6.25.1/include/asm-arm/arch-ixp4xx/hardware.h
+--- linux-2.6.25.4.orig/include/asm-arm/arch-ixp4xx/hardware.h
++++ linux-2.6.25.4/include/asm-arm/arch-ixp4xx/hardware.h
@@ -45,5 +45,6 @@
#include "nslu2.h"
#include "nas100d.h"
@@ -557,10 +557,10 @@ Index: linux-2.6.25.1/include/asm-arm/arch-ixp4xx/hardware.h
+#include "fsg.h"
#endif /* _ASM_ARCH_HARDWARE_H */
-Index: linux-2.6.25.1/include/asm-arm/arch-ixp4xx/irqs.h
+Index: linux-2.6.25.4/include/asm-arm/arch-ixp4xx/irqs.h
===================================================================
---- linux-2.6.25.1.orig/include/asm-arm/arch-ixp4xx/irqs.h
-+++ linux-2.6.25.1/include/asm-arm/arch-ixp4xx/irqs.h
+--- linux-2.6.25.4.orig/include/asm-arm/arch-ixp4xx/irqs.h
++++ linux-2.6.25.4/include/asm-arm/arch-ixp4xx/irqs.h
@@ -128,4 +128,11 @@
#define IRQ_DSMG600_PCI_INTE IRQ_IXP4XX_GPIO7
#define IRQ_DSMG600_PCI_INTF IRQ_IXP4XX_GPIO6