aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-2.6.39/0005-MIPS-Lantiq-Add-platform-device-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/patches-2.6.39/0005-MIPS-Lantiq-Add-platform-device-support.patch')
-rw-r--r--target/linux/lantiq/patches-2.6.39/0005-MIPS-Lantiq-Add-platform-device-support.patch19
1 files changed, 0 insertions, 19 deletions
diff --git a/target/linux/lantiq/patches-2.6.39/0005-MIPS-Lantiq-Add-platform-device-support.patch b/target/linux/lantiq/patches-2.6.39/0005-MIPS-Lantiq-Add-platform-device-support.patch
index 917993fdba..ff376ea21a 100644
--- a/target/linux/lantiq/patches-2.6.39/0005-MIPS-Lantiq-Add-platform-device-support.patch
+++ b/target/linux/lantiq/patches-2.6.39/0005-MIPS-Lantiq-Add-platform-device-support.patch
@@ -25,8 +25,6 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
create mode 100644 arch/mips/lantiq/xway/devices.c
create mode 100644 arch/mips/lantiq/xway/devices.h
-diff --git a/arch/mips/lantiq/Makefile b/arch/mips/lantiq/Makefile
-index a268391..e5dae0e 100644
--- a/arch/mips/lantiq/Makefile
+++ b/arch/mips/lantiq/Makefile
@@ -4,7 +4,7 @@
@@ -38,9 +36,6 @@ index a268391..e5dae0e 100644
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
-diff --git a/arch/mips/lantiq/devices.c b/arch/mips/lantiq/devices.c
-new file mode 100644
-index 0000000..7b82c34
--- /dev/null
+++ b/arch/mips/lantiq/devices.c
@@ -0,0 +1,122 @@
@@ -166,9 +161,6 @@ index 0000000..7b82c34
+ pr_err("kernel is compiled without PCI support\n");
+}
+#endif
-diff --git a/arch/mips/lantiq/devices.h b/arch/mips/lantiq/devices.h
-new file mode 100644
-index 0000000..2947bb1
--- /dev/null
+++ b/arch/mips/lantiq/devices.h
@@ -0,0 +1,23 @@
@@ -195,8 +187,6 @@ index 0000000..2947bb1
+extern void ltq_register_pci(struct ltq_pci_data *data);
+
+#endif
-diff --git a/arch/mips/lantiq/xway/Makefile b/arch/mips/lantiq/xway/Makefile
-index 9c85ff9..74ce438 100644
--- a/arch/mips/lantiq/xway/Makefile
+++ b/arch/mips/lantiq/xway/Makefile
@@ -1,4 +1,4 @@
@@ -205,9 +195,6 @@ index 9c85ff9..74ce438 100644
obj-$(CONFIG_SOC_XWAY) += clk-xway.o prom-xway.o
obj-$(CONFIG_SOC_AMAZON_SE) += clk-ase.o prom-ase.o
-diff --git a/arch/mips/lantiq/xway/devices.c b/arch/mips/lantiq/xway/devices.c
-new file mode 100644
-index 0000000..a71b3b5
--- /dev/null
+++ b/arch/mips/lantiq/xway/devices.c
@@ -0,0 +1,98 @@
@@ -309,9 +296,6 @@ index 0000000..a71b3b5
+ platform_device_register_simple("ltq_asc", 0,
+ ltq_ase_asc_resources, ARRAY_SIZE(ltq_ase_asc_resources));
+}
-diff --git a/arch/mips/lantiq/xway/devices.h b/arch/mips/lantiq/xway/devices.h
-new file mode 100644
-index 0000000..51f56b5
--- /dev/null
+++ b/arch/mips/lantiq/xway/devices.h
@@ -0,0 +1,18 @@
@@ -333,6 +317,3 @@ index 0000000..51f56b5
+extern void ltq_register_ase_asc(void);
+
+#endif
---
-1.7.2.3
-