aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/cortexa53.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/image/cortexa53.mk')
-rw-r--r--target/linux/mvebu/image/cortexa53.mk17
1 files changed, 8 insertions, 9 deletions
diff --git a/target/linux/mvebu/image/cortexa53.mk b/target/linux/mvebu/image/cortexa53.mk
index 1436c1bd23..ff8f2c0930 100644
--- a/target/linux/mvebu/image/cortexa53.mk
+++ b/target/linux/mvebu/image/cortexa53.mk
@@ -1,3 +1,11 @@
+define Device/glinet_gl-mv1000
+ $(call Device/Default-arm64)
+ DEVICE_VENDOR := GL.iNet
+ DEVICE_MODEL := GL-MV1000
+ SOC := armada-3720
+endef
+TARGET_DEVICES += glinet_gl-mv1000
+
define Device/globalscale_espressobin
$(call Device/Default-arm64)
DEVICE_VENDOR := Marvell
@@ -69,12 +77,3 @@ define Device/methode_udpu
BOOT_SCRIPT := udpu
endef
TARGET_DEVICES += methode_udpu
-
-define Device/glinet_gl-mv1000
- $(call Device/Default-arm64)
- DEVICE_TITLE := GL.iNet GL-MV1000
- DEVICE_DTS := armada-gl-mv1000
- SUPPORTED_DEVICES := glinet,gl-mv1000
-endef
-TARGET_DEVICES += glinet_gl-mv1000
-